ID Number: Q66709
1.00 1.10 1.11 4.20
OS/2
Summary:
SYMPTOMS
When SQL Server tries to start during installation, the following
error message is displayed:
Unable to start SQL Server.
CAUSE
Either hardware or software problems were encountered while Setup
was trying to start SQL Server.
RESOLUTION
The following are several reasons why the SQL Server service may
be unable to start during the installation process:
- There is not enough room on your hard disk for the OS/2 swap
file (SWAPPER.DAT). Make sure you have at least 15 to 20 MB of
free space on the hard disk where your SWAPPER.DAT file is
located. Starting up SQL Server may use 8 MB or more of disk
space for the SWAPPER.DAT file.
- The NUMSERVICES parameter is set too low. On both Microsoft's
OS/2 LAN Manager and IBM's LAN Server, you must set the
NUMSERVICES parameter high enough to handle all of the services
the server can run. This parameter is located in the IBMLAN.INI
file for IBM LAN Server, and in the LANMAN.INI file for OS/2
LAN Manager.
- You may be experiencing a hardware problem: the SQLSERVR.EXE
file may have been installed on a bad disk sector. Run the
CHKDSK utility to determine if the problem might be hardware
related. If it is a bad disk sector, run CHKDSK with the Fix
option and completely reinstall SQL Server.
- The wrong CONFIG.SYS file may have been updated. During the
installation, when SQL Server modifies the CONFIG.SYS file, it
modifies the first CONFIG.* file it finds. Therefore, when SQL
Server is being started, the PATH in the CONFIG.SYS file may
not have been set properly. Consequently, you will not be
allowed to start the SQL Server service unless you are located
in the C:\SQL\BINP subdirectory.
Note: This problem should not be related to the sharing of IPC$.
This problem would show up during the first part of the
installation process, during the checking of the system
configuration.
Additional reference words: 1.00 1.10 1.11 4.20