ID Number: Q82063
2.00 2.00a 2.00b 2.00c
MS-DOS
Summary:
SYMPTOMS
The following information applies to LAN Manager version 2.0, 2.0a,
2.0b, or 2.0c workstations, running under MS-DOS version 3.3, 4.0,
or 5.0.
If the PRINT SCREEN key is pressed from an MS-DOS workstation, the
following problems may be encountered:
- Nothing happens, or the print job sits in the queue and does not
print. (This is the most common case.)
- The workstation halts.
- The MS-DOS prompt returns in up to 10 minutes or it does not
return at all.
- The machine cold boots. (Rare)
Often, the first print screen command completes successfully, but
the problem appears on the second or third use of the PRINT SCREEN
key.
The above problems are more evident when using EMM386.
CAUSE
In the early revisions of LAN Manager, use of the SHIFT+PRINT
SCREEN key function suffered from kernel/redirector timing
problems, and the decision was made not to build the function into
the product. The lack of the SHIFT+PRINT SCREEN key function was
not the result of an oversight. These timing problems have since
been resolved, and in LAN Manager 2.0b, the SHIFT+PRINT SCREEN key
functionality was built into the enhanced redirector. This change
was made because of many customer requests; the basic redirector
was not changed.
RESOLUTION
This problem has been corrected in LAN Manager version 2.1. PRINT
SCREEN key functionality has been built into LAN Manager 2.1 basic
workstations as well.
WORKAROUND
If you do not have LAN Manager 2.1, try one of the following
options:
- Try using the PRTSC utility.
- If the user already has Microsoft Word on the workstation, he/she
can use the built-in Microsoft Word utility, CAPTURE.COM. This
utility is loaded into memory similar to a TSR
(terminate-and-stay-resident) program and requires about 20K.
When the user presses SHIFT+PRINT SCREEN, the contents of the
screen are captured to a file. The user can then print the file
at his/her convenience from Word. CAPTURE.COM can also be
unloaded from memory to save the 20K if the user doesn't need to
perform a print screen for some time. Page 397 of the "Using
Microsoft Word" manual gives an explanation of this utility.
Print Screen Usage
------------------
To use the PRINT SCREEN key function across the network, the user must
first be working on an enhanced MS-DOS workstation. The primary
printer port must be redirected to the network printer; for example,
"net use lpt1: \\print_spooler\share (queue) name". Users not running
MS-DOS 5.0 must send an end-of-job marker to the printer. This can be
accomplished by using the PRTSC utility furnished with LAN Manager.
This is a TSR that can be started automatically in the workstation's
AUTOEXEC.BAT file.
Once the user has sent the print job, he/she needs to press the
CTRL+ALT+PRINT SCREEN key combination, which will send the end-of-job
marker and allow the screen to print. Those users who are trying to do
a print screen from a basic workstation can sometimes get the PRINT
SCREEN key function to perform properly, but they need to have loaded
"Graphics" and be in the graphics mode. Without this they will
experience either beeps, or nothing at all.