PRB: Cannot Access Users Portion of LAN Manager Accounts Menu

ID Number: Q63372

2.00

OS/2

Summary:

SYMPTOM

After installing OS/2 LAN Manager version 2.0 and OS/2 version 1.21,

the Users option on the Accounts menu may not be accessible to set

up a new administrative account.

After logging on as ADMIN PASSWORD, entering NET ADMIN, and

receiving a pop-up message stating that you have administrative

privileges, the following error may be returned when trying to

check the information on your account:

NET2227: The user account system has not been started

CAUSE

The user account system (UAS) can be started as long as a good copy

of the database file (NET.ACC) is present. Once the UAS is running

(it is started by the workstation), accounts can be added or

deleted, regardless of the server role.

If share-level security was chosen at install time, NET.ACC was

renamed to NETACC.BKP; hence, the workstation is unable to start

the UAS. This should be indicated in the error log with the

following error messages:

NET3166: Error trying to start the UAS

NET3190: A Netwksta internal error occurred CloseRef:ActiveCnt

going negative.

WORKAROUND

To work around this problem, rename NETACC.BKP to NET.ACC in the

\LANMAN\ACCOUNTS directory and then restart the workstation.

Additional reference words: 2.00