ID Number: Q65206
3.00
WINDOWS
Summary:
SYMPTOMS
When an application is debugged with Microsoft CodeView for Windows
(CVW), one or more of the following three problems occurs:
1. After the first CreateWindow function call, each window painted
by Windows is solid black.
2. The video display loses synchronization (is smeared or
scrambled).
3. Moving the mouse causes random characters (garbage) to appear on
the display.
CAUSE
An incompatible VGA video card is installed in the system. Some VGA
cards do not work with CVW and the default VGA display driver
because of the method that the card supports enhanced video memory
or video memory greater than 256K.
RESOLUTION
The VGA display driver included with the Microsoft Windows Software
Development Kit (SDK) version 3.0 that allows those with
incompatible video cards to use CVW. Do not install this driver for
normal use, however, because Windows is unable to run DOS
(Microsoft MS-DOS or PC-DOS) applications while the driver is
installed. See below for information on installing this alternate
driver.
More Information:
To install the VGA display driver, perform the following seven steps:
1. Copy VGA.DRV in the SYSTEM directory of the Windows installation
(by default, C:\WINDOWS\SYSTEM) to VGAN.DRV (N for normal). This
process creates a backup copy of the driver that can be copied back
to VGA.DRV if the new driver does not work correctly.
2. Copy VGA.DRV from the Development Files disk in the Windows SDK
version 3.0 to VGAD.DRV (D for debug) in the SYSTEM directory of
the Windows installation.
3. Load the SYSTEM.INI file into a text editor.
4. Find the [boot] section at the top of the SYSTEM.INI file.
5. Edit the display.drv= line to read as follows:
display.drv=vgad.drv
6. Save the SYSTEM.INI file.
7. Start Windows.
When the application has been successfully debugged using CVW, perform
the following two steps to restore full Windows functionality:
1. Edit the SYSTEM.INI file by changing the display.drv= line to read
as follows:
display.drv=vga.drv
2. Save the SYSTEM.INI file and restart Windows.
If problems with the display continue to occur when the mouse is moved
after the debug display driver has been reinstalled, perform the
following five additional steps (which involve the mouse driver):
1. Review the AUTOEXEC.BAT system file to see if a mouse driver is
loaded. One line in the file may contain only the command mouse.
2. If a mouse driver is loaded, edit the line in the AUTOEXEC.BAT file
to specify the full path to the appropriate mouse driver in the
directory in which Windows is installed.
3. If a Windows mouse driver is already being used, edit the mouse
line in the AUTOEXEC.BAT file to append the /Y option switch to the
mouse command. This option switch disables the driver's "sprite"
capability.
4. Save the AUTOEXEC.BAT file, shut down the system, and reboot the
machine.
5. Run Windows and CVW.
Additional reference words: 3.00 3.0