The information in this article applies to:
- Microsoft Access versions 1.0, 1.1
SYMPTOMS
In the sample database ORDENTRY.MDB you can print a sample invoice
form. When you print the form, the Ship To information will contain
the city name twice, and will not print the address line.
CAUSE
There is an error in the ShipToInfo procedure in the Order Routines
module. The error will occur only if you enter a Ship To address.
RESOLUTION
Correct the error in the ShipToInfo procedure as follows:
- From the File menu, choose Open Database to open the ORDENTRY.MDB
database. Bypass the autoexec macro by pressing SHIFT when you
double-click the database name, or when you choose OK. (If you do
not press SHIFT when opening the database, the autoexec macro will
run and you will not be able to modify the procedure.)
- In the Database window, choose the Module button. Select the Order
Routines module and choose Design.
- Press F2 and the View Procedures dialog box will appear. In the
bottom half of this box is the Procedures box. In the Procedures
box, select the ShipToInfo procedure, and choose OK.
- Find the line that starts with:
stAddress$ = ConvertNulls(DLookup("ShipCity"
Change this line so that the beginning reads:
stAddress$ = ConvertNulls(DLookup("ShipAddress"
Leave the remainder of the line intact.
- Save the changes and close the database.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Access versions
1.0 and 1.1. This problem no longer occurs in Microsoft Access version 2.0.
MORE INFORMATION
Steps to Reproduce Behavior
- Open the ORDENTRY.MDB database.
- From the View menu, choose Orders.
- Select Add Orders and choose Select.
- Select any employee from the Employee ID box and choose OK.
- Select any customer from the Bill To box.
- In the Ship To box enter your name, address, city, state and
ZIP code.
- Select the printer icon in the bottom-left corner of the form or
choose Print from the File menu.
|