ACC1x: Order Entry Ship To Address Contains City Information

Last reviewed: May 14, 1997
Article ID: Q100471
The information in this article applies to:
  • Microsoft Access versions 1.0, 1.1

SYMPTOMS

In the sample database ORDENTRY.MDB you can print a sample invoice form. When you print the form, the Ship To information will contain the city name twice, and will not print the address line.

CAUSE

There is an error in the ShipToInfo procedure in the Order Routines module. The error will occur only if you enter a Ship To address.

RESOLUTION

Correct the error in the ShipToInfo procedure as follows:

  1. From the File menu, choose Open Database to open the ORDENTRY.MDB database. Bypass the autoexec macro by pressing SHIFT when you double-click the database name, or when you choose OK. (If you do not press SHIFT when opening the database, the autoexec macro will run and you will not be able to modify the procedure.)

  2. In the Database window, choose the Module button. Select the Order Routines module and choose Design.

  3. Press F2 and the View Procedures dialog box will appear. In the bottom half of this box is the Procedures box. In the Procedures box, select the ShipToInfo procedure, and choose OK.

  4. Find the line that starts with:

          stAddress$ = ConvertNulls(DLookup("ShipCity"
    

    Change this line so that the beginning reads:

          stAddress$ = ConvertNulls(DLookup("ShipAddress"
    

    Leave the remainder of the line intact.

  5. Save the changes and close the database.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Access versions 1.0 and 1.1. This problem no longer occurs in Microsoft Access version 2.0.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Open the ORDENTRY.MDB database.

  2. From the View menu, choose Orders.

  3. Select Add Orders and choose Select.

  4. Select any employee from the Employee ID box and choose OK.

  5. Select any customer from the Bill To box.

  6. In the Ship To box enter your name, address, city, state and ZIP code.

  7. Select the printer icon in the bottom-left corner of the form or choose Print from the File menu.


Keywords : DcmNwd kberrmsg kbusage
Version : 1.0 1.1
Platform : WINDOWS
Hardware : X86
Issue type : kbdocerr
Resolution Type : Info_Provided


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: May 14, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.