ACC: Network Problems May Cause "Segment Load Failure" Error

Last reviewed: June 3, 1997
Article ID: Q109730
The information in this article applies to:
  • Microsoft Access versions 1.0, 1.1, 2.0, 7.0, 97

SYMPTOMS

Moderate: Requires basic macro, coding, and interoperability skills.

You receive a "Segment Load Failure" error message or another memory- conflict error message.

In Microsoft Access 97, you may also receive a "System Process - Lost Delayed Write Error" or an Invalid Bookmark Error message when viewing data from linked tables.

CAUSE

A "Segment Load Failure" error message can occur if Microsoft Access is running on a network or is accessing data on a network, and the network server stops functioning correctly.

A segment load failure implies that there was a problem moving information from secondary storage, such as a network server disk, to main memory. If a network server stops functioning correctly, expected information may not be available to Microsoft Access.

A "System Process - Lost Delayed Write Error" error message implies that Microsoft Access had a problem writing data from its buffers to secondary storage. This can occur if the connection to a Network share stops functioning correctly. An "Invalid bookmark" error message will also occur numerous times for each field on each record in the current table or query that you are viewing if the share on which your data is stored becomes unavailable.

RESOLUTION

The following suggestions may help you to diagnose the problem:

  • Make a backup of all critical data and run disk diagnostic software, such as the MS-DOS CHKDSK command, to check the integrity of the workstation and server disk drives.
  • If the workstation has a complete Microsoft Access installation, quit and then restart Microsoft Access on the workstation, and see if it operates correctly without using the network for any services. If the problem continues with Microsoft Access operating in isolation, begin checking the workstation for memory conflicts.
  • If the database is being accessed off a network server, consider copying it to the local workstation to isolate whether the problem is workstation or server specific.
  • If the server is required, just start the server and the Microsoft Access workstation to test Microsoft Access. If the problem does not occur at this point, you can start and diagnose other workstations one by one.


Keywords : EvnNtw GnlMu kberrmsg
Version : 1.0 1.1 2.0 7.0 97
Platform : WINDOWS
Hardware : X86
Issue type : kbprb
Resolution Type : Info_Provided


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: June 3, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.