ACC2: User Needs Read/Write Privileges for WORKDIR Folder

Last reviewed: June 3, 1997
Article ID: Q117912
The information in this article applies to:
  • Microsoft Access version 2.0

SYMPTOMS

Novice: Requires knowledge of the user interface on single-user computers.

When you start Microsoft Access on a network workstation, you may receive the following error messages:

   Could not open SYSTEM.MDA

   -and-

   Can't find SYSTEM.MDA

Or, you receive the following compile error messages while Microsoft Access is loading the add-ins:

   Compile time error

   -and-

   Tried to load module with duplicate procedure name

CAUSE

Microsoft Access was installed on a network server with the WORKDIR directory set to Read-Only.

RESOLUTION

Make sure that all Microsoft Access users have at least Read and Write privileges for the WORKDIR directory.

Within some network environments, it may also be necessary to give users Create privileges, especially when using Microsoft Access for the first time. This would allow Microsoft Access to create the SYSTEM.LDB file within the WORKDIR directory.

MORE INFORMATION

When you start Microsoft Access on a network workstation, you must have write privileges for the following .MDA files in the WORKDIR directory on the server: SYSTEM.MDA, WZLIB.MDA, WZTABLE.MDA, WZBLDR.MDA, WZFRMRPT.MDA, and WZQUERY.MDA (the Wizard files). The UTILITY.MDA file is installed in the parent directory of the WORKDIR directory (whether this is an Office install or Microsoft Access install) and should be read-only.

To verify that the error messages are caused by incorrect privileges set for the WORKDIR directory, follow these steps:

  1. Set the attributes for the WORKDIR directory (not just the individual files) to Read/Write.

  2. Use a supervisory-level login to start Microsoft Access on the workstation.

REFERENCES

For more information about network installations, see the "Network Installations" topic in the ACREADME.HLP file (in the ACCESS directory).


Additional query words: share
Keywords : EvnNtw kbsetup
Version : 2.0
Platform : WINDOWS
Hardware : X86
Issue type : kbprb
Resolution Type : Info_Provided


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: June 3, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.