ACC2: GP Fault Using Query Wizards and Mono VGA Video Driver

Last reviewed: May 14, 1997
Article ID: Q121468
The information in this article applies to:
  • Microsoft Access version 2.0

SYMPTOMS

Novice: Requires knowledge of the user interface on single-user computers.

When you use the Find Unmatched Query Wizard or the Crosstab Query Wizard, you may receive a general protection (GP) fault error message.

CAUSE

You are using the Monochrome VGA video driver for your Microsoft Windows video driver.

RESOLUTION

To work around this problem, use the standard VGA video driver, and select the Monochrome color scheme in Windows Control Panel.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Access version 2.0. This problem no longer occurs in Microsoft Access version 7.0 or in Microsoft Access version 2.0 running under Windows 95.

MORE INFORMATION

The Monochrome VGA video driver is a popular driver for use on laptop computers. However, using this video driver will cause a GP fault when you use the Microsoft Access Wizards mentioned earlier in this article.

Steps to Reproduce Problem

NOTE: This example assumes that you have the Monochrome VGA video driver installed.

WARNING: Following these steps will cause a general protection fault on your computer. Make sure you save and close any open work on your computer before following these steps.

  1. Start Microsoft Access and open the sample database NWIND.MDB.

  2. In the Database window, choose the Query button, and then choose the New button. In the New Query box, choose the Query Wizards button.

  3. In the "Which Wizard do you want?" box, select Find Unmatched Query. Choose OK.

  4. In the "Select the table or query that contains the records you want to see in the query's results..." box, select Categories, and then choose the Next button.

  5. In the "Select the table or query that contains the related records" box, select Customers, and then choose the Next button.

  6. In the Fields In Categories box, select Category Name. In the Fields In Customers box, select Customer ID. Choose the "<=>" button, and then choose the Next button.

  7. Choose the ">>" button, and then choose the Next button. Note that you receive a GP fault error message.


Additional query words: gpf
Keywords : kberrmsg kbusage WzProb
Version : 2.0
Platform : WINDOWS
Hardware : X86
Issue type : kbbug
Resolution Type : kbworkaround


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: May 14, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.