ACC2: Cannot Share Some Microsoft Access Wizards

Last reviewed: May 12, 1997
Article ID: Q121662
The information in this article applies to:
  • Microsoft Access version 2.0

SYMPTOMS

Moderate: Requires basic macro, coding, and interoperability skills.

When you are trying to use a Microsoft Access Wizard, builder, or add-in, you may receive one of the following messages:

  • For the Database Documentor add-in or the Print Definitions command:

    Another user or another instance of Microsoft Access is currently Printing Definitions or using the Database Documentor.

    -or-

    Can't Update. Database or Object is Read Only."

  • For the Table Wizard or Field Builder:

    Another user or another instance of Microsoft Access is currently using the Table Wizard or the Field Builder.

  • For the Combo Box Wizard or the List Box Wizard:

    Unable to launch the Wizard. Make sure that there is only one instance of the List Box or Combo Box Wizard running.

  • For the Option Group Wizard:

    Another user or another instance of Microsoft Access is using the Option Group Wizard.

CAUSE

When you perform an administrative installation of Microsoft Access on a network server, Setup places the wizard library databases in a sub-directory called WORKDIR. If users have network permissions to use the WORKDIR subdirectory, they can share the wizard files and try to run them concurrently.

Some wizards modify the library database in which they reside and cannot be run concurrently. The following wizards cannot be used by more than one person at a time:

    Wizard, Builder, or Add-in    Library Database
    ----------------------------------------------
    Table Wizard                  WZTABLE.MDA
    Field Builder                 WZTABLE.MDA
    Database Documentor           WZLIB.MDA
    Combo Box Wizard              WZBLDR.MDA
    List Box Wizard               WZBLDR.MDA
    Option Group Wizard           WZBLDR.MDA

RESOLUTION

Method 1

You can give each network user his or her own copy of the wizards by copying the library database files to each user's local hard disk (or personal directory on the server) and modifying the MSACC20.INI file. To do so, follow these steps:

  1. At an MS-DOS command prompt, type the following commands to copy the library database files from the server to each user's local hard disk:

          copy f:\access\workdir\wztable.mda c:\access
          copy f:\access\workdir\wzbldr.mda c:\access
          copy f:\access\workdir\wzlib.mda c:\access
    

    NOTE: These commands assume that Microsoft Access is installed in the ACCESS directory on network drive F and that each user has Microsoft Access installed in the ACCESS directory on drive C. If this is not the case, modify the commands to use the correct drives and paths for your installation.

  2. Use any text editor (such as Notepad) to open the MSACC20.INI file in the Windows directory on each user's local hard disk. Modify the following lines

          [Libraries]
          F:\ACCESS\WORKDIR\WZLIB.MDA=RW
          F:\ACCESS\WORKDIR\WZTABLE.MDA=RW
          F:\ACCESS\WORKDIR\WZBLDR.MDA=RW
          F:\ACCESS\WORKDIR\WZQUERY.MDA=RW
          F:\ACCESS\WORKDIR\WZFRMRPT.MDA=RW
    

    to read:

          [Libraries]
          C:\ACCESS\WZLIB.MDA=RW
          C:\ACCESS\WZTABLE.MDA=RW
          C:\ACCESS\WZBLDR.MDA=RW
          F:\ACCESS\WORKDIR\WZQUERY.MDA=RW
          F:\ACCESS\WORKDIR\WZFRMRPT.MDA=RW
    

  3. Save and then close the MSACC20.INI file.

Method 2

You can install Wiznet.exe, which has updated versions of several Microsoft Access wizards. The updated versions allow for concurrent use (by multiple users) of the following wizards:

   Attachment Manager
   List Box Wizard
   Combo Box Wizard
   Option Group Wizard

For information on how to obtain Wiznet.exe, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q149360
   TITLE     : ACC2: Multiuser Wizards Available on MSL

REFERENCES

Microsoft Access "Building Applications," version 2.0, Chapter 15, "Using Library Databases and Dynamic-Link Libraries," pages 345-376

For additional information on using the Microsoft Access Wizards in 7.0, please see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q162358
   TITLE     : ACC95: Err "Access Can't Find the Wizard" (Workstation
               Setup)

   ARTICLE-ID: Q162357
   TITLE     : ACC95: Err "Access Can't Find the Wizard" (Local Setup)


Additional query words: multiuser shared error
Keywords : GnlMu kberrmsg kbusage
Version : 2.0
Platform : WINDOWS
Hardware : X86
Issue type : kbprb
Resolution Type : kbworkaround


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Last reviewed: May 12, 1997
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