ACC2: Error Message "Couldn't Open SYSTEM.MDA"

Last reviewed: May 14, 1997
Article ID: Q123589
The information in this article applies to:
  • Microsoft Access version 2.0

SYMPTOMS

Moderate: Requires basic macro, coding, and interoperability skills.

When you start Microsoft Access, you may receive either of the following error messages:

  • Couldn't open SYSTEM.MDA

    -or-

  • <Database> is corrupted or is not a database file. Attempt to repair?

CAUSE

The Microsoft Jet database engine version 2.0 may erroneously leave an internal database flag set that in some cases results in one of the error messages stated above.

RESOLUTION

To reset the internal database flag, have all users log out of the database and then run the repair utility. (To run the repair utility, choose Repair from the File menu.) If you receive the "Couldn't open SYSTEM.MDA" error message, all users should quit Microsoft Access. When the first user logs back in, the SYSTEM.MDA file is repaired automatically. No data will be lost as a result of the internal database flag being set erroneously.

STATUS

This problem no longer occurs with the Microsoft Jet database engine version 2.5, which is available with the Microsoft Access version 2.0 Service Pack. For information about how to obtain the Service Pack, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q122927
   TITLE     : WX1124: Microsoft Access Version 2.0 Service Pack

You can also obtain the Microsoft Access Version 2.0 Service Pack through Microsoft FastTips by ordering item number 1124 from the FastTips Main Menu.


Additional query words: jet25 jet 2.5
Keywords : GnlBaddb kbusage
Version : 2.0
Platform : WINDOWS
Hardware : X86
Issue type : kbbug
Resolution Type : kbworkaround


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: May 14, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.