ACC2: GPF Running Wizards on Computers w/ Pre-Installed Office

Last reviewed: April 2, 1997
Article ID: Q129306
The information in this article applies to:
  • Microsoft Access version 2.0
  • Microsoft Office for Windows version 4.3

SYMPTOMS

Moderate: Requires basic macro, coding, and interoperability skills.

When you attempt to use a Microsoft Access Wizard, such as the Form Wizard or the Report Wizard, on Gateway 2000 and P590 computers that have Microsoft Office for Windows version 4.3 pre-installed, you may receive a general protection (GP) fault.

The pre-installation process that Gateway uses seems to cause a problem with the DAO2016.DLL file. In some cases, the problem can extend to other shared dynamic-link libraries (DLLs) as well. Gateway has been notified of the problem.

CAUSE

The GP fault may be caused by a faulty Microsoft Access DLL file called DAO2016.DLL.

RESOLUTION

In most cases, replacing the DAO2016.DLL file corrects the problem.

Instructions about how to replace the DAO2016.DLL file (and other files if necessary) are detailed below. We recommend that you manually replace the files rather than use the uninstall feature of the Microsoft Access Setup program. Using the uninstall feature can have adverse consequences on an existing installation, such as:

  • Overwriting an existing SYSTEM.MDA file.
  • Losing special icon properties.
  • Overwriting the MSACC20.INI file settings.

You should first attempt to replace the DAO2016.DLL file because it is the most common cause of the problem. If this does not work, replace the other files listed below.

To replace the faulty files, follow these steps:

  1. Quit Microsoft Access if it is running.

  2. Use the following steps to replace the files:

        a. If you have a CD-ROM, remove the DLL files and re-install Microsoft
           Access. Because they may be overwritten, save any files (such as the
           SYSTEM.MDA or the MSACC20.INI file, or any databases you have
           created) that you want to retain.
    

           If you want to expand the DLL file from the CD-ROM, you must use the
           Microsoft extract utility, EXTRACT.EXE, which you can find on the
           first Microsoft Access Disk Image. For further information about
           this type of extraction, search on the words "CAB" and "Extract"
           here in the Microsoft Knowledge Base
    

        b. If you have disks, run the Microsoft file decompression utility,
           DECOMP.EXE. You can find this file on Disk 1 of the original
           Microsoft Access disks. Run the DECOMP.EXE file with the following
           parameter:
    

             DECOMP -f
    
           The -f parameter forces a new file to replace the old file.
    
           When you are prompted "Enter the name and/or path for the compressed
           file:," insert Disk 2 of the original Microsoft Access disks, and
           then enter the name and path of the compressed DAO2016.DLL file.
    
           NOTE: Files compressed with the DECOMP.EXE file end with an
           underscore (_). For instance, enter:
    
             a:\dao2016.dl_
    
           When you are prompted "Enter the name and/or path for the
           decompressed file:," enter the name and/or path of your
           Windows\SYSTEM directory and the file name. For instance,
           enter:
    
             c:\windows\system\dao2016.dll
    
           NOTE: If you entered the correct name and/or path, you receive the
           message:
    
             Wrote 437408 bytes to output file
             'C:\WINDOWS\SYSTEM\DAO2016.DLL'
    
    

  3. Start Microsoft Access. If you receive a GP fault again, backup any files (such as the SYSTEM.MDA or the MSACC20.INI file, or any databases you have created) that you want to retain. Run the Microsoft Access Setup program with the Remove All option and reinstall Microsoft Access.

  4. Restart Microsoft Access. If you receive a GP fault again, you may have faulty source disks or a bad CD-ROM.

The Gateway 2000 and P590 computers are manufactured by Gateway 2000, Inc, a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding these products' performance or reliability.


Keywords : kb3rdparty kbsetup StpOthr
Version : 2.0
Platform : WINDOWS
Hardware : X86
Issue type : kbinfo


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Last reviewed: April 2, 1997
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