ACC2: "Unable to Get System Fixed Font" Error Message

Last reviewed: January 7, 1998
Article ID: Q132057
The information in this article applies to:
  • Microsoft Access version 2.0

SYMPTOMS

When you start Microsoft Access, you may receive the following two error messages:

   Unable to get system fixed font.

   Can't start Microsoft Access. Please try again.

CAUSE

In the [boot] section of the SYSTEM.INI file, you have a missing or invalid value for the "fixedfon.fon" line. For example:

   [boot]
   fixedfon.fon=

RESOLUTION

You can reset the "fixedfon.fon" setting in the SYSTEM.INI file using these steps:

NOTE: On Microsoft Windows NT version 3.51, you must make these changes in the registry to correct the value of fixed.fon.

  1. Open the SYSTEM.INI file in a text editor, such as NOTEPAD.EXE.

  2. In the [boot] section, locate the line beginning with "fixedfon.fon" (without quotation marks).

  3. Enter a valid value for the fixedfon.fon setting. The following value works on most computers:

          [boot]
          fixedfon.fon=vgafix.fon
    

    NOTE: If there is no fixedfon.fon setting in the [boot] section, then add the entire line as shown above.

  4. Save and close the SYSTEM.INI file.

  5. Restart Windows to load your modified SYSTEM.INI file. When you start Microsoft Access, you should not receive the "Unable to get system fixed font" error message.

MORE INFORMATION

Steps to Reproduce Problem

  1. Open the SYSTEM.INI file in a text editor, such as NOTEPAD.EXE.

  2. In the [boot] section, locate the line beginning with "fixedfon.fon" (without quotation marks).

  3. Enter an incorrect value for the fixedfon.fon setting. For example:

          [boot]
          fixedfon.fon=
    

  4. Save and close the SYSTEM.INI file.

  5. Restart Windows to reload the SYSTEM.INI file. When you start Microsoft Access, you should receive the two error messages listed in the "Symptoms" section.

REFERENCES

For more information about other SYSTEM.INI settings, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q96109
   TITLE     : ACC: Troubleshooting Setup & Installation Problems
               (1.x, 2.0)
Keywords          : EvnPrfm kbenv kberrmsg
Version           : 2.0
Platform          : WINDOWS
Hardware          : x86
Issue type        : kbprb
Solution Type     : Info_Provided


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Last reviewed: January 7, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.