The information in this article applies to:
SYMPTOMS
Novice: Requires knowledge of the user interface on single-user computers.
When you print a report, a blank page appears between every printed page of
the report or a blank mailing label appears between every printed label.
CAUSE
Blank pages or mailing labels are generated when a report or label is
wider or longer than the specified page. One or more of the following
conditions can cause blank pages or mailing labels to be generated:
- The total width of the form or report, plus the width of the left and
right margins, exceed the page width (which is usually 8.5 inches).
- The page size exceeds the user-defined paper size.
- In the Report Wizard dialog box, the "Adjust the field width so all
fields will fit on a page" check box is not selected. Because of this,
the Report Wizard may locate fields or controls off the page.
- On the Layout tab in the Page Setup dialog box, the Same As Detail check
box is not selected in the Item Size section.
RESOLUTION
To prevent blank pages or mailing labels, do one or more of the following:
- If the total width exceeds the page width, reduce the width of the form
(or report), reduce the left or right margins, or reduce all three.
Use the following formula:
(Form or Report Width)+(Left Margin)+(Right Margin)<=(Page Width)
To view or change the Width property, open the form or report's property
sheet. If you reduce the width of a form or report, be sure to move the
fields and controls to match the new size.
To view the left and right margin values, on the File menu, click Page
Setup.
If you continue to receive blank pages or blank mailing labels, check
the print settings in the Page Setup dialog box. To do so, follow these
steps:
1. On the File menu, click Page Setup.
2. In the Page Setup dialog box, click the Layout tab.
3. Under Item Size, verify that the Same As Detail box is selected. If
so, the width and height listed will match the dimensions of the
detail section of the report. If not, these settings will override
the detail settings of the report and may cause blank pages to be
printed.
NOTE: Item Size is usually used for multiple-column reports. You
must ensure that all the columns fit on the report form when you set
these values.
- If the page size is user-defined, Microsoft Access reads the settings
that you specify for that printer. If your report page exceeds this
user-defined paper size, your report will include blank pages.
A new page size is not be available in Microsoft Access until you first
specify one in the Windows Printers folder. To do so, follow these
steps.
NOTE: Only dot-matrix printer drivers have a user-definable page
option. Laser printer drivers do not.
1. Click the Start button, point to Settings, and then click Printers.
2. In the Printers dialog box, using the right mouse button, click the
printer you want to change, and then click Properties on the menu
that appears.
3. Click the Paper tab. In the Paper Size box, select User-Defined. A
dialog box appears in which you can adjust the settings.
- If you use the Report Wizard to generate the report, click to select the
"Adjust the field width so all fields will fit on a page" check box.
Once you select this check box, the Report Wizard assumes a page 8.5
inches wide and sizes the fields and controls accordingly. If you clear
the check box, the resulting report width may exceed the page size.
- The Same As Detail option is useful when you create a detailed,
multiple-column report and want the detail section to be a different
size than the other sections. However, if you clear this check box,
blank pages may be printed if the width defined for the detail section
of the report is greater than the page size specified. Unless you want
multiple columns in the detail section, make sure the Same As Detail
check box is checked. This box, found under Item Size in the Page Setup
dialog box on the Layout tab, is selected by default. The Width property
is set to match the report's Width property.
STATUS
This behavior is by design.
REFERENCES
For more information about blank pages on reports, search the Help Index
for "troubleshooting printing" and then "My report prints blank pages," or
ask the Microsoft Access 97 Office Assistant.
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