ACC2: Troubleshooting GPFs in MS Access 2.0 under Windows 95

Last reviewed: July 22, 1997
Article ID: Q139084
The information in this article applies to:
  • Microsoft Access version 2.0
  • Microsoft Windows 95

SYMPTOMS

Novice: Requires knowledge of the user interface on single-user computers.

When you run Microsoft Access version 2.0 under Microsoft Windows 95, you may receive a general protection (GP) fault error message, such as the following:

   MSACCESS caused a GP Fault in module KRNL386.EXE at 0001:00001a2a.

CAUSE

A GP fault signifies that something unexpected has happened within the Windows environment, typically an improper memory access. For example, a program or a Windows component may try to read or write to a memory location that has not been allocated to it, potentially overwriting and corrupting other program code in that area of memory.

Another situation where a GP fault may occur involves the passing of parameters between programs and the Windows environment. Invalid parameters can cause invalid instructions to be executed, resulting in GP faults. This is usually the result of a program's internal program code incorrectly passing specific data that could not be correctly interpreted by Windows or a Windows-based program.

RESOLUTION

To resolve a GP fault error message under Windows 95, try these troubleshooting steps:

  1. Restart Windows in Safe Mode so that the operating system uses its default settings, such as VGA monitor, no network, Microsoft mouse driver, and the minimum device drivers.

    To restart Windows in Safe Mode, follow these steps:

        a. Restart your computer by clicking the Start button, clicking Shut
           Down, and then clicking Restart The Computer.
    

        b. When you see the message "Starting Windows 95," press F5.
    

    After restarting Windows, run Microsoft Access and try to reproduce the GP fault. If you cannot reproduce the problem in safe mode, then the cause is probably a Windows configuration issue.

  2. To test for a Windows configuration issue, you can step through the startup process to see if any device drivers or terminate-and-stay- resident programs (TSR) cause problems with Microsoft Access.

    To step through the Windows startup process, follow these steps:

        a. Restart your computer by clicking the Start button, clicking Shut
           Down, and then clicking Restart The Computer.
    

        b. When you see the message "Starting Windows 95," press F8.
    

        c. Press 5 to select the Step-by-Step Confirmation option.
    

        d. When you are asked to confirm Startup options, respond as follows:
    

             Option                                             Response
             ===========================================================
    
             Load DriveSpace Driver?                               Y
             Process the system registry?                          Y
             Create a startup log file (Bootlog.txt)?              Y
             Process your startup device drivers (Config.sys)?     Y
             Device=<path>\Himem.sys?                              Y
             Device=<path>\Ifshlp.sys?                             Y
             Device=<path>\Dblbuff.sys?                            Y
             Device=<path>\Setver.exe?                             Y
             Process your startup command file (Autoexec.bat)?     Y
             Load the Windows graphical user interface?            Y
             Load all Windows Drivers?                             Y
    
          NOTE: When processing the startup device drivers (Config.sys) and
          startup command file (Autoexec.bat), Windows will ask you to confirm
          each setting. You can choose not to load individual files as a way of
          finding out which one is causing the configuration problem.
    
          For more information about using Step-by-Step Confirmation when
          starting Windows 95, please see the following article in the
          Microsoft Knowledge Base:
    
             ARTICLE-ID: Q136337
             TITLE     : Troubleshooting Windows 95 Startup Problems and
                         Error Messages
    
    

  3. If you installed a beta version of Windows 95 on your computer and used the same folder for the final retail version, you can try reinstalling Windows 95 to a new, clean folder. This eliminates any problems caused by beta version files which may have remained on your system.

  4. If you installed Microsoft Access before you installed Windows 95, try reinstalling Microsoft Access to a new, clean folder.

  5. To find out if the GP fault is display-related, you can try changing the way Windows 95 uses your video card.

    To change how Windows uses your graphics hardware, follow these steps:

        a. Click the Start button, point to Settings, and then click Control
           Panel.
    

        b. Double-click the System icon.
    

        c. Click the Performance tab, and then click the Graphics button in the
           Advanced Settings section.
    

        d. Move the Hardware Acceleration slider to the None setting (all the
           way to the left), and then click OK.
    

        e. In the System Properties box, click OK.
    

        For more information about troubleshooting video problems, please see
        the following article in the Microsoft Knowledge Base:
    

           ARTICLE-ID: Q127139
    
           TITLE     : Troubleshooting Video Problems in Windows 95
    
    

  6. You can try installing the Microsoft Access version 2.0 Service Pack, which replaces existing files in your current Microsoft Access version 2.0 installation. The Service Pack includes the following updated files:

        - The Microsoft Jet database engine (version 2.5).
    

        - The OLE dynamic-link libraries (version 2.02).
    

        - Btrieve, Paradox, and xBASE installable ISAM drivers.
    

    For more information about how to obtain the Microsoft Access version 2.0 Service Pack, please see the following article in the Microsoft Knowledge Base:

          ARTICLE-ID: Q122927
    
          TITLE     : WX1124: Microsoft Access Version 2.0 Service Pack
    
    

  7. If you are using the Calendar, Scroll Bar, or Data Outline custom control at the time you receive the GP fault, you need to install the Microsoft Access Developer's Toolkit (ADT) Custom Controls Service Pack.

    For more information about how to obtain the Microsoft Access Developer's Toolkit (ADT) Custom Controls Service Pack, please see the following article in the Microsoft Knowledge Base:

          ARTICLE-ID: Q133341
    
          TITLE     : WX1200: Microsoft Access Developer's Toolkit Custom
                      Controls Service Pack
    
    

  8. You can run the Make Compatible utility (Mkcompat.exe), which enables you to specify environment settings for Windows 3.x programs.

    To run the Mkcompat.exe file, follow these steps:

        a. Click the Start button, and then click Run.
    

        b. In the Open box, type "mkcompat" (without the quotation marks), and
           then click OK.
    

        c. On the File menu, click Choose Program.
    

        d. In the Choose Program box, locate Msaccess.exe.
    

        e. In the Make Compatible box, select options that may affect the
           operation you were performing when the GP fault occurred. For
           example, try selecting "Lie about Windows version number" or "Give
           application more stack space."
    

        f. On the File menu, click Save.
    

        g. On the File menu, click Advanced Options.
    

        h. Again, select options that may affect the operation you were
           performing when the GP fault occurred.
    

        i. On the File menu, click Save.
    

        j. On the File menu, click Exit.
    

REFERENCES

For more information about running Windows 3.x applications in Windows 95, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q120174
   TITLE     : Running Applications That Require Windows 3.1 or Later
 

	
	


Keywords : EvnGpf kbenv
Version : 2.0
Platform : WINDOWS
Hardware : X86
Issue type : kbprb
Resolution Type : Info_Provided


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Last reviewed: July 22, 1997
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