ACC95: "Invalid Page Fault in VBA232.DLL" Error Message

Last reviewed: June 2, 1997
Article ID: Q141222
The information in this article applies to:
  • Microsoft Access version 7.0

SYMPTOMS

Novice: Requires knowledge of the user interface on single-user computers.

In Microsoft Access version 7.0, you may receive the following error message while developing, over time, an application with code, for example, when you work on a form containing event procedures or when you start the application:

   This application has performed an illegal operation and will be shut
   down.

If you click the Details button, you see the following information:

   Msaccess.exe caused an invalid page fault in module VBA232.DLL.

NOTE: This error can also occur when you print a code module in Far East versions of Microsoft Access, which contains DBSC (double-byte character set) characters.

CAUSE

This error message has three possible causes:

  • A confirmed bug in the Visual Basic for Applications Development Environment (VBA232.dll version 2.0.5524)
  • A damaged database
  • Mismatched dynamic link libraries (.dll files) in the \Windows\System folder as a result of installing Microsoft Office Standard for Windows 95 or Microsoft Office Professional for Windows 95 before Microsoft Access 7.0

RESOLUTION

You can resolve this error message by trying the following steps. If you try these in order, you can stop at whichever step eliminates the problem and skip the remaining steps:

  1. Install the update to Vba232.dll. For more information about this update and how to obtain it, please see the following article in the Microsoft Knowledge Base:

          ARTICLE-ID: Q147529
    
          TITLE     : ACC95: Updated Vba232.dll Available on MSL
    
    

  2. Run the Compact Database and Repair Database commands. Whenever you receive an invalid page fault error message, you should run these commands on the current database to correct any potential damage to the database's structure or data.

    NOTE: The Compact Database command should be run on a regular basis (for example, nightly). The Repair Database command should ONLY be run if the Microsoft Jet database engine returns an error message indicating that the Repair should be run. Before you run the Repair Database command, you should make a backup copy of the database.

  3. Rename the current database file and try to open it again. When you assign a new name, you can assign either a long file name or an MS-DOS 8.3 file name (that is, an 8-character name followed by a 3-character extension).

  4. Create a new database, import all of the objects from the original database to the new database, open a module window within the new database, click Compile All Modules on the Run menu, and click Save All Modules on the File menu.

  5. If none of the above steps solves the error message, then the cause is most likely mismatched .dll files on your system. You should uninstall both Microsoft Office for Windows 95 (Standard or Professional) and Microsoft Access 7.0 and reinstall them. For specific details about how to uninstall and reinstall these applications, please see the following article in the Microsoft Knowledge Base:

          ARTICLE-ID: Q148424
    
          TITLE     : ACC: Troubleshooting Invalid Page Faults in MS Access 95
                      and 97
    
       NOTE: Be sure to install Microsoft Access first and Microsoft Office
       second when you reinstall the two programs. This setup order is
       important to avoid the problem of mismatched .dll files on your system.
       Also, because the uninstall process may remove Vba232.dll, you should
       repeat step 1 to make sure you have the latest version of Vba232.dll.
    
    

STATUS

Microsoft has confirmed this to be a problem in Microsoft Access version 7.0. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.


Additional query words: ipf
Keywords : kberrmsg kbsetup StpGnrl
Version : 7.0
Platform : WINDOWS
Hardware : X86
Issue type : kbbug
Resolution Type : Info_Provided


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: June 2, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.