The information in this article applies to:
- Microsoft Access version 7.0, 97
SYMPTOMS
Novice: Requires knowledge of the user interface on single-user computers.
While installing Microsoft Access for Windows 95 version 7.0 on a computer
running Microsoft Windows NT version 3.51 or 4.0, you may receive the
following error message:
Msjtrclr.dll could not be registered.
-or-
Can't create System.mdw.
-or-
Disk or Network error.
These same errors may also occur when you install Microsoft Access through
the Office Professional for Windows 95 product.
NOTE: The "Disk or Network error" message can also occur when attempting to
run Microsoft Access 97.
CAUSE
This error can occur if you have an invalid setting for the TEMP or
TMP environment variables or the drive specified for the TEMP or TMP
environment variable does not have enough free disk space.
STATUS
This behavior does not occur while installing Microsoft Access 97.
RESOLUTION
You can verify or set the TEMP environment variable by following these
steps:
- For NT 3.51, in Program Manager, double-click the Main icon and within
this icon group, double-click the Control Panel icon.
For NT 4.0, double-click the My Computer icon, and within the My
Computer window, double-click the Control Panel icon.
- In Control Panel, double-click the System icon.
- Notice the last three boxes in the System dialog box called User
Environment Variables for <username>, Variable, and Value, respectively.
These three boxes are used to set or update the TEMP environment
variable. Examples of valid settings are as follows:
TEMP = C:\TEMP
TMP = C:\TEMP
To set up these examples, follow these steps:
a. In the Variable box, type "temp" (without the quotation marks).
b. Press the TAB key to move to the Value box and type "c:\temp"
(without the quotation marks).
c. Click the Set button to add these values to the User Environment
Variables for <username> box.
- To create the TMP environment variable, repeat steps a - c.
- Click OK to close the System dialog box. Close Control Panel, and then
close Main.
- Start File Manager and look for a directory with the same name and
location as was listed in the User Environment Variables for <username>
box. If no TEMP directory exists, create one. If the directory has a
different name or location, you can repeat steps 1 - 3 to update the
TEMP environment variable.
- Verify that the drive containing the TEMP directory has sufficient disk
space. If this number is less than 4,000,000 bytes (4 MB), free up some
hard drive space by removing unnecessary files.
- Verify that the TEMP directory is empty. If files exist, you can delete
any .TMP files that are not currently in use. These files usually have a
modified date earlier than the current session of Windows.
NOTE: It is recommended that you quit all Windows programs as well
as Windows itself before deleting any .TMP files.
Once you have a valid TEMP directory, reinstall Access. If you received
the "Can't create System.mdw" error then run the Workgroup Administrator
(Wrkgadm.exe) program to create a new System.mdw.
|