ACC2: Troubleshooting "Can't Find Installable ISAM" Error

Last reviewed: October 28, 1997
Article ID: Q150494
The information in this article applies to:
  • Microsoft Access version 2.0

SYMPTOMS

Novice: Requires knowledge of the user interface on single-user computers.

When you import data from a Microsoft FoxPro, Paradox, dBASE, or Btrieve file, you may receive the following error message:

   Can't find installable ISAM.

CAUSE

This error is usually caused by an incorrect entry in the MSACC20.INI file or a corrupted dynamic link library (.DLL) file on your computer. The error can also occur if the newer BTRV200.DLL from the Microsoft Access Service Pack 2.0 is used with original version of MSAJT200.DLL.

RESOLUTIONS

Check the MSACC20.INI File

To do so, follow these steps:

  1. Open the MSACC20.INI file in a text editor, such as Notepad.

  2. Locate the [Installable ISAMs] section and note the paths for the ISAM drivers:

          [Installable ISAMs]
          Paradox 3.X=C:\Windows\System\Pdx200.dll
          Paradox 4.X=C:\Windows\System\Pdx200.dll
          FoxPro 2.5=C:\Windows\System\Xbs200.dll
          FoxPro 2.6=C:\Windows\System\Xbs200.dll
          FoxPro 2.0=C:\Windows\System\Xbs200.dll
          dBASE III=C:\Windows\System\Xbs200.dll
          dBASE IV=C:\Windows\System\Xbs200.dll
          Btrieve=C:\Windows\System\Btrv200.dll
    

  3. Start Windows Explorer (or File Manager) and locate the ISAM drivers listed in the MSACC20.INI file. If the drivers are not found in the specified location, you should reinstall the ISAM drivers. To do so, follow these steps:

        a. In a text editor, open the MSACC20.INI file and comment the ISAM
           section by entering a semicolon (;) in front of each line, for
           example:
    

           [Installable ISAMs]
           ;Paradox 3.X=C:\Windows\System\Pdx200.dll
           ;Paradox 4.X=C:\Windows\System\Pdx200.dll
           ;FoxPro 2.5=C:\Windows\System\Xbs200.dll
           ;FoxPro 2.6=C:\Windows\System\Xbs200.dll
           ;FoxPro 2.0=C:\Windows\System\Xbs200.dll
           ;dBASE III=C:\Windows\System\Xbs200.dll
           ;dBASE IV=C:\Windows\System\Xbs200.dll
           ;Btrieve=C:\Windows\System\Btrv200.dll
    

        b. Save the MSACC20.INI file and close the text editor.
    

        c. Start the Microsoft Access Setup program.
    

        d. Click the Add/Remove Programs button.
    

        e. Click to clear "ISAM drivers" to uninstall the Installable ISAM
           drivers, and then click Continue. Follow the instructions on screen
           to complete the uninstall process.
    

           NOTE: If the ISAM drivers check box is disabled, quit Setup, rename
           the following files, and begin again from Step c:
    

            BTRV200.DLL
            PDX200.DLL
            XBS200.DLL
    
        f. Start the Microsoft Access Setup program again to reinstall the ISAM
           drivers.
    
        g. Click the Add/Remove Programs button.
    
        h. Click to select the "ISAM drivers" box, and then click Continue.
           Follow the instructions on screen to complete the installation. This
           Setup process will update the [Installable ISAMs] section in the
           MSACC20.INI file to the correct settings.
    
    

  4. If the error message continues at this point, completely uninstall and reinstall Microsoft Access. To do so, follow these steps:

        a. Back up all .MDB files created with Microsoft Access.
    

        b. Start Windows Explorer (or File Manager).
    

        c. Locate and rename the following files (all but one of these files
           are located in the \Windows\System directory):
    

            BTRV200.DLL
            COMPOBJ.DLL
            CTL3D.DLL
            MSAJT200.DLL
            MSAJU200.DLL (file located in Access directory)
            PDX200.DLL
            STDOLE.TLB
            STORAGE.DLL
            TYPELIB.DLL
            XBS200.DLL
    
          If you are using Windows 95, copy the following files from the
          \Windows\Sysbckup folder (a hidden folder) to the \Windows\System
          folder:
    
            COMPOBJ.DLL
            CTL3D.DLL
            STDOLE.TLB
            STORAGE.DLL
            TYPELIB.DLL
    
        d. Start the Microsoft Access Setup program.
    
        e. Click the Remove All button.
    
        f. When you receive the prompt, "Are you sure you want to remove this
           Application," click Yes.
    
        g. Follow the instructions on the screen to complete the removal
           process.
    
        h. Start Microsoft Access Setup again. Follow the instructions on the
           screen to install the program.
    
    

  5. If you are using Microsoft Windows 3.1 and the error message continues at this point, resolve the problem by rebuilding the Windows registry.

    For more information about rebuilding the Windows 3.1 registry, please see the following article in the Microsoft Knowledge Base:

          ARTICLE-ID: Q80393
    
          TITLE:      How to Rebuild the Default Windows REG.DAT File
    
    

To Test for Mismatched DLL Files

Check the modified date of MSAJT200.DLL. If the date is prior to November 20, 1994, re-run the Microsoft Access Service Pack 2.0.

MORE INFORMATION

The third-party products discussed here are manufactured by vendors independent of Microsoft; we make no warranty, implied or otherwise, regarding these products' performance or reliability.


Additional query words: gray grey grayed greyed
Keywords : IsmGnrl kb3rdparty kberrmsg
Version : 2.0
Platform : WINDOWS
Hardware : x86
Issue type : kbprb
Solution Type : Info_Provided


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Last reviewed: October 28, 1997
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