ACC95: Unable to Create 32-Bit ODBC Data Source

Last reviewed: July 11, 1997
Article ID: Q150500
The information in this article applies to:
  • Microsoft Access version 7.0

SYMPTOMS

Advanced: Requires expert coding, interoperability, and multiuser skills.

After you install Microsoft Access version 7.0 and include the Microsoft Desktop ODBC drivers, you are unable to set up a data source using the 32-bit ODBC Administrator in Control Panel.

CAUSE

There was a problem with the installation of the ODBC components on your computer.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Access version 7.0. This problem no longer occurs in Microsoft Access 97.

RESOLUTION

IMPORTANT: The following resolution contains information about editing the registry. Before you edit the registry, you should first make a backup copy of the registry files (System.dat and User.dat). Both are hidden files in the Windows folder.

For information about how to edit the registry, view the Changing Keys And Values online Help topic in Registry Editor (Regedit.exe). Note that you should make a backup copy of the registry files (System.dat and User.dat) before you edit the registry.

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows 95. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

To resolve the problem, follow these steps:

  1. Uninstall the Microsoft Desktop OBDC Drivers of Microsoft Access 7.0 by following these steps:

        a. In Windows 95, click the Start button, point to Settings, and then
           click Control Panel.
    

        b. In Control Panel, double-click Add/Remove Programs.
    

        c. In the Add/Remove Programs Properties dialog box, select Microsoft
           Access 7.0, and then click Add/Remove.
    

        d. In the Microsoft Access Setup box, click Add/Remove.
    

        e. In the Maintenance box, select the Data Access option, and then
           click Change Option.
    

        f. Deselect Microsoft Desktop OBDC Drivers and click OK and Continue.
           When asked to confirm the removal of the components, click Yes.
    

  2. Remove any leftover keys in the Microsoft Registry from the installation of ODBC components by following these steps:

        a. Start the Registry Editor. To do so, click the Start button, click
           Run, and then type "regedit" (without the quotation marks) in the
           Run dialog box. Click OK.
    

        b. In the Registry Editor dialog box, locate the following key:
    

              HKEY_Local_Machine\Software\ODBC\Odbcinst.ini\SQL Server
    
        c. Select any keys listed under \SQL Server.
    
        d. On the File menu, click Delete. When asked to confirm the deletions,
           click Yes.
    
        e. Close the Registry Editor.
    
    

  3. Reinstall the Microsoft Desktop OBDC Drivers in Microsoft Access 7.0 by following these steps:

        a. In Windows 95, click the Start button, point to Settings, and then
           click Control Panel.
    

        b. In Control Panel, double-click Add/Remove Programs.
    

        c. In the Add/Remove Programs Properties dialog box, select Microsoft
           Access 7.0, and then click Add/Remove.
    

        d. In the Microsoft Access Setup box, click Add/Remove.
    

        e. In the Maintenance box, select the Data Access option, and then
           click Change Option.
    

        f. Select Microsoft Desktop OBDC Drivers and click OK and Continue. If
           asked to confirm the installation, click Yes.
     
    
    
    	
    	


Keywords : kbusage OdbcProb
Version : 7.0
Platform : WINDOWS
Hardware : X86
Issue type : kbprb
Resolution Type : kbfix


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Last reviewed: July 11, 1997
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