ACC: Can't Open a Database Created with an Earlier Version

Last reviewed: January 5, 1998
Article ID: Q152216
The information in this article applies to:
  • Microsoft Access versions 7.0, 97

SYMPTOMS

Advanced: Requires expert coding, interoperability, and multiuser skills.

When you link a Microsoft Access 2.0 database (.mdb) file in Microsoft Access 7.0 or 97, you may receive the following error message:

   Can't open a database created with a previous version of your
   application.

Similarly, using Visual Basic to link a Microsoft Access 2.0 .mdb file or opening an application in Visual Basic that contains a link to a Microsoft Access 2.0 .mdb file can generate this same error message.

NOTE: This error also occurs when converting from an earlier version of Microsoft Access if the Jet 2.x key is missing.

CAUSE

In Microsoft Access 7.0, the Microsoft Jet database engine version 2.x key is missing from the Windows Registry under the following key:

   HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\3.0\ISAM Formats

In Microsoft Access 97, the Microsoft Jet database engine version 2.x key is missing from the Windows Registry under the following key:

   HKEY_LOCAL_MACHINE\Software\Microsoft\Jet\3.5\ISAM Formats

This can be caused by removing a run-time application created with the Microsoft Office 97 Developer Edition Tools (or Microsoft Access Developer's Toolkit for Microsoft Access 7.0). When the application is removed, the Microsoft Jet database engine version 2.x key is removed from the Windows Registry.

This registry setting is necessary for any application that uses the Jet 2.x ISAM driver to access a Jet 2.x table/query.

RESOLUTION

You can run Setup to reset the Registry settings. To do so, follow these steps:

  1. In Windows 95 or Windows NT 4.0, click the Start button, and then click Run (or in Windows NT 3.51, click Run on the File menu in Program Manager or File Manager.)

  2. Insert Disk 1 of the Microsoft Access 7.0 or 97 disks into a floppy drive on your computer. Or, insert the Microsoft Office 95 Professional CD or the Microsoft Office 97 Professional CD into the CD-ROM drive.

  3. Type a command to run the Microsoft Access Setup program using the /y switch, for example:

          a:\setup /y
    

  4. In the Installation Maintenance Program box, click Reinstall. The Setup program updates the Windows Registry for Microsoft Access.

  5. When Setup is complete, try starting Microsoft Access and linking the Microsoft Access 2.0 database file.
Keywords          : kbenv kberrmsg
Version           : 7.0 97
Platform          : WINDOWS
Hardware          : x86
Issue type        : kbprb
Solution Type     : Info_Provided


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: January 5, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.