ACC97: Can't Print Black Lines on Report When Spool Set to Raw

Last reviewed: March 5, 1998
Article ID: Q164254
The information in this article applies to:
  • Microsoft Access 97

SYMPTOMS

When you try to print a black line on a report that you are creating in Microsoft Access 97, the line is not printed. However, if you view the report in Print Preview, the line is present. If you change the line's Border Color property to a color other than black (0), the line is printed.

This behavior also occurs with tables, queries, and datasheet views of forms in which you change the gridline color of the cells to black. MultiFax

CAUSE

When the Spool Data Format setting for the printer you are using is set to RAW, black lines will not print on your report, and gridlines will not print on your table, query, or form in Datasheet view.

RESOLUTION

If you want to have black lines print on your report and gridlines print on your table, query, or form in Datasheet view, change the spool setting of the printer to EMF (Enhanced Metafile format). Otherwise, change the color for the lines or gridlines you are printing to another color.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Access 97. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

The Enhanced Metafile format (EMF) allows Windows 95 to use a full 32-bit GDI instruction set. When you print using the EMF spooling option, Windows 95 creates an EMF that contains a complete set of instructions that re-create the image as printed output. When you change your Spool Data Format printer setting to EMF, Windows can better handle printing black lines.

Steps to Reproduce Problem

  1. Open Microsoft Access 97 and the sample database Northwind.mdb.

  2. Open the Invoice report in Design view.

  3. Click on the line just below the Logo.

  4. Change the Border Color property of the line to 0 (black).

  5. Set the Spool data format setting for your HP Laserjet printer to RAW by doing the following:

        a. On the Start menu, point to Settings, and then click Printers.
           Select your HP Laserjet printer.
    

        b. In the Printers dialog box, using the right mouse button, click
           your printer, and then click Properties.
    

        c. In the <Printer> Properties dialog box, click the Details tab, and
           then click Spool Settings.
    

        d. In the Spool Settings box, in the Spool Data Format box, change the
           setting to RAW. Click OK. Click OK again to close the <Printer>
           Properties box.
    

  6. Print the first page of the Invoice report. Note that the line does not appear on the report.

REFERENCES

For more information about changing print driver settings, please see the following article in the Microsoft Knowledge Base:

  ARTICLE-ID: Q128345
  TITLE     : Troubleshooting Printing Problems in Windows 95


Additional query words: gridlines
Keywords : ACCT PtrGraph PtrPrev kbprint
Version : 97
Platform : WINDOWS
Hardware : x86
Issue type : kbbug
Solution Type : Info_Provided


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Last reviewed: March 5, 1998
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