The information in this article applies to:
SYMPTOMS
Novice: Requires knowledge of the user interface on single-user computers.
When you create a link to a text file from Microsoft Access 97 and then
move the text file to another folder, you may receive the following error
message when you try to use the Linked Table Manager to refresh the link:
The text file specification '<text filename>' does not exist. You can't
import, export, or link using the specification.
CAUSE
A specification is created when you create a link to a text file. If you
quit Microsoft Access, move the text file to another folder, and then
restart Microsoft Access, the specification no longer works because the
path to the text file has changed.
RESOLUTION
Remove the link to the text file. Then, recreate the link to the text file
in its new location.
MORE INFORMATION
Steps to Reproduce Behavior
- Open the sample database Northwind.mdb and select the Customers table.
- On the File menu, click Save As/Export.
- In the Save As dialog box, click to select "To an External File or
Database," and then click OK.
- In the "Save Table 'Customers' In" dialog box, select Text Files in the
Save As Type box.
- In the File Name text box, type "C:\My Documents\Customers.txt"
(without the quotation marks), and then click Export.
- When the Export Text Wizard appears, click Finish, and then click OK.
- On the File menu, point to Get External Data, and then click Link
Tables.
- In the Link dialog box, select Text Files in the Files Of Type box.
- Locate the folder C:\My Documents, select Customers.txt, and then click
Link.
- On the first three screens of the Link Text Wizard, click Next.
- On the last screen of the Link Text Wizard, type CustomersLinked in
the Linked Table Name box, and then click Finish.
- When you receive the message that Microsoft Access has finished
linking, click OK.
- Quit Microsoft Access.
- Open Windows Explorer and move C:\My Documents\Customers.txt to another
folder.
- Start Microsoft Access and open the sample database Northwind.mdb.
- On the Tools menu, point to Add-Ins, and then click Linked Table
Manager.
- In the Linked Table Manager dialog box, click to select the
CustomersLinked and the "Always Prompt for New Location"
check boxes, and then click OK.
- In the "Select New Location of CustomersLinked" dialog box, locate
Customers.txt in its new location, and then click Open.
Note that you receive the following error:
The text file specification 'Customers Link Specification' does not
exist. You can't import, export, or link using the specification.
REFERENCES
For more information about linking text files, search the Help Index for
"text files, importing or linking," and then select "Import or link data."
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