ACC: "Can't Update..." Error Opening Replica Read-Only

Last reviewed: July 10, 1997
Article ID: Q171208
The information in this article applies to:
  • Microsoft Access versions 7.0, 97

SYMPTOMS

Advanced: Requires expert coding, interoperability, and multiuser skills.

When you open a database replica in Microsoft Access 7.0 or 97, you may receive the following error message:

   Can't Update. Database or object is read-only.

This may be followed by the following error message, depending on your version of Microsoft Access.

In Microsoft Access 97

   Microsoft Access couldn't create storage space for a Visual Basic
   module.

   -or-

   Automation error.

   Catastrophic failure.

In Microsoft Access 7.0

   OLE Automation Error

CAUSE

You are trying to open the replica read-only immediately after it was created or synchronized with another replica.

RESOLUTION

When you open a replica for the first time after its creation or synchronization with another replica, open it for read/write access. This will ensure that Microsoft Access is able to compile and store the Visual Basic for Applications project in the replica. The next time you open the replica, you will be able to open it for read-only access.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Access 7.0 and 97. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

The first time you open a replica after its creation, or after synchronization with another replica whose Visual Basic for Applications project has changed, Microsoft Access will attempt to compile and store the replica's Visual Basic for Applications project. The compiled Visual Basic for Applications project is stored in an internal system table.

When you open a replica for the first time after its creation or synchronization with another replica, Microsoft Access cannot store the compiled Visual Basic for Applications project in the replica if you are opening it read-only. This results in the error(s) listed in the "Symptoms" section.

Steps to Reproduce Behavior

  1. Create a new, blank database.

  2. On the Tools Menu, point to Replication, and then click Create Replica.

  3. Click Yes when prompted to close the current database.

  4. Click No when prompted to create a backup of the database.

  5. Select a location for the new replica, and then click OK. You will receive a confirmation message indicating the database has been converted to a Design Master, and that a replica has been created. Click OK to close the message.

  6. On the File menu, click Open Database.

  7. Locate the replica you created in step 5, right-click it to view its shortcut menu, and then click Open Read-Only. Note that you receive the error message:

          Can't Update. Database or object is read-only.
     
    
    
    	
    	


Keywords : kberrmsg RplGen
Version : 7.0 97
Platform : WINDOWS
Hardware : x86
Issue type : kbbug
Resolution Type : Info_Provided


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: July 10, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.