ACC97: Invalid DAO Reference Causes an IPF in MSACCESS.EXE

Last reviewed: March 3, 1998
Article ID: Q177264
The information in this article applies to:
  • Microsoft Access 97

SYMPTOMS

Novice: Requires knowledge of the user interface on single-user computers.

In Microsoft Access 97, when you try to do any of the following

  • open a database with a startup form
  • view, create, or execute Visual Basic code in a form's class module
  • start a Microsoft Access 97 Wizard

you may receive one of the following error messages.

In Windows 95

   ActiveX component can't create object.

   -or-

   This application has performed an illegal operation and will be shut
   down.

If you click the Details button, you see the following additional information:

    Invalid Page Fault in MSACCESS.EXE



In Windows NT

   An application error has occurred and an application error log is
   being generated. MSACCESS.EXE

   -or-

   MSACCESS.EXE caused an exception: Access Violation in MSACCOPT.DBG

CAUSE

The Dao350.dll file was not properly registered when Microsoft Access 97 was installed. This behavior occurs when you run setup for Microsoft Access 97 or Microsoft Office 97 Professional Edition, and the Dao350.dll file already exists on your hard drive. If the file already exists, the setup program does not reregister the file correctly.

RESOLUTION

There are three methods that you can use to resolve this issue. Each method is more extensive than the one before it, so you may want to try each method in the order listed until the error message goes away.

Method 1: Use Regsvr32.exe to Register the DAO Files

Regsvr32.exe is a program that you can use to register dynamic link library (.dll) files or ActiveX Controls in Microsoft Windows 95 or Microsoft Windows NT.

If Regsvr32.exe is not already on your hard drive, please see the following article in the Microsoft Knowledge Base for information about obtaining a copy of the file:

   ARTICLE-ID: Q161983
   TITLE     : ACC: Regsvr32.exe Available on MSL

Follow these steps to register the Data Access Objects (DAO) DLL on your computer using Regsvr32.exe:

  1. Quit Microsoft Access if it is running.

  2. Verify that Regsvr32.exe is in your Windows\System folder, for example

           \Windows\System or \Winnt\System32.
    

  3. Depending on the operating system you are using, do one of the following:

        a. In Microsoft Windows 95 or Microsoft Windows NT version 4.0, on
           the taskbar, click Start, and then click Run.
    

        b. In Microsoft Windows NT version 3.51, in Program Manager or File
           Manager, on the File menu, click Run.
    

  4. In the Run dialog box, in the Open text box (or the Command Line box in Microsoft Windows NT version 3.51), type the following command:

          Regsvr32.exe C:\progra~1\common~1\micros~1\dao\dao350.dll
    

    NOTE: The path to Dao350.dll may be different on your computer.

  5. Start Microsoft Access and attempt to perform the process that caused the error.

    NOTE: An alternative method of registering DLLs is to use Windows Explorer to find the DLL, double-click it, in the Open With Box, select Regsvr32.exe, and then click OK. This creates a permanent association of all DLLs with Regsvr32.exe. You can easily register other unregistered DLLs by double-clicking them.

Method 2: Remove the DAO Folder and Reinstall

  1. Depending on which program you installed, remove Microsoft Office 97 Professional Edition or Microsoft Access 97 from your computer as follows.

        For Microsoft Windows 95 or Microsoft Windows NT version 4.0
        ------------------------------------------------------------
    

         a. On the taskbar, click Start, point to Settings, and then click
    
            Control Panel.
    
         b. Double-click the Add/Remove Programs icon.
    
         c. In the Add/Remove Programs Properties dialog box, select Microsoft
            Office 97 Professional Edition or Microsoft Access 97, and then
            click Add/Remove.
    
         d. In the Installation Maintenance dialog box, click Remove All.
            Confirm that you want to remove the program.
    
        For Microsoft Windows NT version 3.51
        -------------------------------------
    
         a. In Program Manager, double-click the Microsoft Office 97
            Professional Edition or Microsoft Access 97 program group.
    
         b. Double-click the Microsoft Office Setup or Microsoft Access Setup
            icon.
    
         c. In the Installation Maintenance dialog box, click Remove All.
            Confirm that you want to remove the program.
    
    

  2. Remove the following folder and any files it contains from your hard drive. Depending on your operating system, and whether you installed the operating system as a stand-alone version or an upgrade from an earlier version, the folder should be in one of the following paths:

          \Program Files\Common Files\Microsoft Shared\Dao
    

          -or-
    

          \Winnt\Msapps\Dao
    

  3. Run Setup to reinstall Microsoft Office 97 Professional Edition or Microsoft Access 97. Do not choose a Compact installation.

  4. Start Microsoft Access 97 and try to perform the process that caused the error.

Method 3: Remove the Program, Delete Leftover Files, and Reinstall

  1. Complete step 1 from Method 2 to remove all of Microsoft Office 97 Professional Edition or Microsoft Access 97 from your hard drive.

  2. Manually delete all Microsoft Office 97 Professional Edition or Microsoft Access 97 files left on your hard drive after Setup removes the program.

    For a list of files to remove, please see the following articles in the Microsoft Knowledge Base:

          ARTICLE-ID: Q163997
    
          TITLE     : ACC97: How to Completely Uninstall Microsoft Access 97
    
          ARTICLE-ID: Q160044
          TITLE     : OFF97: Clicking "Remove All" in Setup Leaves Some Files
    
       If you are removing Microsoft Office 97 Professional Edition, remove
       the files listed in both articles. If you are removing a stand-alone
       version of Microsoft Access 97, remove the files listed in Q163997.
    
    

  3. Start Microsoft Access and try to perform the process that caused the error.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Access 97. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

Microsoft Excel 97 and Microsoft Visual Basic 5.0 both include copies of the file Dao350.dll. The version numbers of these files are as follows:

   Product                                            Version of Dao350.dll
   ------------------------------------------------------------------------
   Microsoft Excel 97 or Microsoft Office 97 Standard  3.50.3428.0
   Visual Basic 5.0                                    3.50.3602.0

When you install Microsoft Excel 97, Visual Basic 5.0, or Microsoft Office 97 Standard, before installing Microsoft Access 97, you can receive the error mentioned in the "Symptoms" section. The Dao350.dll file already exists on the system and does not get replaced. This is why you cannot correct the problem described in this article by simply reinstalling Microsoft Access 97 or Microsoft Office 97 Professional Edition.

NOTE: The user may not receive the Invalid Page Fault errors, but may receive errors when trying to run any Microsoft Access 97 Wizards.

For information about troubleshooting a similar issue involving the Microsoft Access Wizards in Microsoft Access 97, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q167591
   TITLE     : ACC97: Microsoft Access Can't Find the Wizard Error Message

REFERENCES

For information about troubleshooting a similar issue in Microsoft Access 95, please see the following articles in the Microsoft Knowledge Base:

   ARTICLE-ID: Q162357
   TITLE     : ACC95: Err "Access Can't Find the Wizard" (Local Setup)

   ARTICLE-ID: Q162358
   TITLE     : ACC95: Err "Access Can't Find the Wizard" (Workstation

   ARTICLE-ID: Q162746
   TITLE     : ACC95: Visual C++ 4.1/4.2 Cause Error Message in MS Access
               95


Additional query words: pra problems with wizards
Keywords : WzProb EvnGpf
Version : WINDOWS:97
Platform : WINDOWS
Hardware : x86
Issue type : kbbug
Solution Type : kbworkaround


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: March 3, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.