The information in this article applies to:
- Microsoft Access version 1.0
SYMPTOMS
You receive the following error message:
ODBC - couldn't find ODBC.DLL
CAUSES
Here are three possible causes:
- The ODBC.DLL file you are using may be old.
- You may have duplicate ODBC.DLL files on your system, and you are
using the wrong one.
- The ODBC.DLL file you are using may be damaged or corrupted.
RESOLUTION
The ODBC.DLL file installed by Microsoft Access version 1.0 is dated
10-16-92, has a size of 44736 bytes, and should be installed in the
\WINDOWS\SYSTEM directory.
MORE INFORMATION
There are other situations that may indirectly cause this error message. To
troubleshoot for these possibilities:
- Use File Manager to search for multiple, corrupted, or outdated
copies of these files:
File Correct Dates and Sizes
---------------------------------------------------
DBNMP3.DLL dated 9-15-92(8241 bytes) or later
SQLSRVR.DLL dated 10-16-92(135792 bytes) or later
NETAPI.DLL depends on the network being used
COMMDLG.DLL dated 10-25-92(89248 bytes) or later
NOTE: The sizes and dates referenced are correct if the files are
installed by Microsoft Access version 1.0.
- Make sure the files listed in step 1 are in their appropriate locations.
All files except NETAPI.DLL are usually installed in the \WINDOWS\SYSTEM
directory. The NETAPI.DLL file is a network specific driver; it is
usually located in the network's program directory, which should be in
the path.
- Use another application, such as Q+E, SAF, or PowerBuilder, on the
same machine to attempt to attach to the same data source. If you
cannot access the data source from another application, you probably
have a network problem with the NETAPI.DLL file or with the server, not
with Microsoft Access or ODBC.
- Attempt to attach another data source, if available, such as another
SQL server. If you can attach to another server, the original server may
be down, or you may need to reconfigure the entry for that server using
the ODBC Administration Utility.
- Attempt to attach the same data source from a different machine. If you
cannot gain access to the SQL server from a different machine, you may
have a network-wide problem, or the SQL server may be down or not
communicating.
- Try increasing your ODBC timeout settings in the ODBC section of the
MSACCESS.INI file.
- Check with the system administrator to see if the SQL server is up,
available for transactions, and operating properly.
- Reinstall ODBC after performing a clean boot and renaming the
ODBC.DLL, DBNMP3.DLL, and SQLSRVR.DLL files.
REFERENCES
Microsoft Access "User's Guide," version 1.0, Appendix D, "Setting up
Microsoft Access on a Network," pages 660-662
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