ACC: "Stored Procedure 'PROCEDURE' Not Found" Error Message

Last reviewed: August 13, 1997
Article ID: Q95061

The information in this article applies to:
  • Microsoft Access versions 1.0, 1.1, 2.0, 7.0, 97

SYMPTOMS

Advanced: Requires expert coding, interoperability, and multiuser skills.

When you try to gain access to the SQL Server, you may receive the error message

   Stored procedure 'PROCEDURE' not found

where 'PROCEDURE' is the name of a stored procedure that cannot be found but is necessary to gain access to the SQL Server.

CAUSE

The SQL Server 4.2 you are attempting to gain access to is not set up correctly. It is missing the required stored procedures.

RESOLUTION

To correct this situation, install the necessary stored procedures on the SQL Server by using the INSTCAT.SQL SQL script file supplied with the Microsoft Access disk set.

MORE INFORMATION

Run INSTCAT.SQL to configure Microsoft SQL Server for use with ODBC, the open database connectivity protocol used by Microsoft Access to link (attach) SQL Server tables. INSTCAT.SQL is the SQL script file that ships with ODBC. You need to run it to set up the stored procedures that provide catalog information used by ODBC.

To install the catalog stored procedures using INSTCAT.SQL, run INSTCAT.SQL using the SQL Server facility ISQL (Interactive SQL) from the MS-DOS command line.

Following is the syntax for this procedure. Note that you need to enter the two lines as one continuous line, and that you do not include the angle braces <> in the command:

   ISQL /U <sa login name> /n /P <password> /S <SQL server name>
   /i <drive:\path\INSTCAT.SQL> /o <drive:\path\output file name>

   Following is a description for each switch:

   /U    Gives the system administrator's login name.
   /n    Eliminates line numbering and prompting for user input.
   /P    Gives the system administrator's Password - case sensitive.
   /S    Gives the name of the server to set up.
   /i    Gives the drive and fully qualified path for INSTCAT.SQL.
   /o    Provides the output file destination for results of the
         process including errors.

Here is a sample ISQL command line:

   ISQL /U sa /n /P SA_Password /S SQL_SERVER /id:\SQL\INSTCAT.SQL
   /o d:\SQL\output.txt

After running INSTCAT.SQL, run the RECONFIGURE command against the MASTER database by using the SQL Administration Facility (SAF) from an MS-DOS client or the server, or run the SQL Administrator program from a Microsoft Windows client.

Other Possible Causes for this Error Message

It is possible that other situations can indirectly cause this error message. Use the following steps to troubleshoot the problem:

  1. Use Windows Explorer (or File Manager in Windows 3.x) to search for multiple, corrupted, or outdated copies of these files:

          ODBC.DLL      dated on or after 10-16-92 containing 44736 bytes
          DBNMP3.DLL    dated on or after 9-15-92 containing 8241 bytes
          SQLSRVR.DLL   dated on or after 10-16-92 containing 135792 bytes
          NETAPI.DLL    depends on the network being used
          COMMDLG.DLL   dated on or after 10-25-92 containing 89248 bytes
    
          NOTE: The sizes and dates referenced are correct if the files are
          installed by Microsoft Access version 1.0.
    
    

  2. Make sure the files listed above are in appropriate locations. All the files except NETAPI.DLL are usually installed in the Windows System folder (directory). The NETAPI.DLL file is a network-specific driver that is usually located in the network's program folder, which should be in the path.

  3. Use another application, such as Q+E, SAF, or PowerBuilder, on the same computer to attempt to link the same data source. If you cannot gain access to the data source from another application, there is probably a problem with the network. That is, there may be a problem with the NETAPI.DLL file or a problem with the SQL database server, not with Microsoft Access or ODBC.

  4. Attempt to link to another data source such as another SQL server. If you are successful, the original server may be down, or you may need to reconfigure the entry for that server using the ODBC Administration Utility.

  5. Attempt to link the same data source from another computer. If you cannot gain access to the SQL database server from another computer, there could be a network-wide problem or the server may be down or not communicating.

  6. Try increasing the ODBC timeout property of your query. In Microsoft Access version 1.x or 2.0 try increasing the ODBC timeout in the MSACC20.INI file. In Microsoft Access 7.0 and 97, try increasing the ODBC timeout in the registry.

    For more information about setting the ODBC timeout in the Windows 95 registry, please see the following article in the Microsoft Knowledge Base:

          ARTICLE-ID: Q139044
    
          TITLE     : ACC95: How to Add Former MSACC20.INI ODBC Section to
                      Registry
    
    

  7. Check with the system administrator to see if the SQL database server is up, available for transactions, and operating correctly.

  8. Reinstall ODBC after restarting the server and renaming the ODBC.DLL, DBNMP3.DLL, and SQLSRVR.DLL files.

REFERENCES

Microsoft SQL Server "Administrator's Guide," version 4.2, pages 205-212


Additional query words: kbtshoot tshoot odbc
Keywords : OdbcOthr kberrmsg kbusage
Version : 1.0 1.1 2.0 7.0 97
Platform : WINDOWS
Hardware : x86
Issue type : kbprb
Solution Type : Info_Provided


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Last reviewed: August 13, 1997
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