The information in this article applies to:
- Microsoft Access versions 1.0, 1.1, 2.0
SYMPTOMS
Novice: Requires knowledge of the user interface on single-user computers.
When you print a report generated in Microsoft Access, a blank page appears
between every printed page of the report or a blank mailing label appears
between every printed label.
CAUSE
Blank pages or blank mailing labels are generated when a report or label is
wider or longer than the specified page. This condition can be caused by
one or more of the following situations:
- The total width of the form or report, plus the widths of the left and
right margins, exceeds the page width (which is usually 8.5 inches).
- The page size exceeds the user-defined paper size.
- You used the Groups/Totals Report Wizard, but did not select the
Fit All Fields On One Page check box. Because of this, the
Report Wizard may have located fields or controls off the page.
- The Same As Detail checkbox has been cleared in the Item size section
under the File menu, Page Setup Layout tab.
RESOLUTION
The following resolutions correspond to each of the four causes described
above:
- Reduce the width of the form or report, reduce the left or right
margins, or reduce all three so that the total width of the form or
report, plus the width of the margins, does not exceed the page width.
Use the following formula:
(Form or Report Width)+(Left Margin)+(Right Margin)<=(Page Width)
Use the form or report's property sheet to view or change the Width
property. Before you reduce the width of a form or report, move the
fields and controls on it to match the new size.
To view the left and right margin values, choose Print Setup from the
File menu.
If problems persist, use the following procedure to check the Print
Setup dimensions:
1. From the File menu, choose Print Setup.
2. Choose More.
3. Under Item Size, verify that the Same As Detail box is selected. If
so, the width and height listed will match the dimensions of the
detail section of the report. If not, these settings will override
the detail settings of the report and may cause blank pages to be
printed.
NOTE: Item Size is usually used for multiple-column reports. You
must ensure that all the columns fit on the report form when you set
these values.
- If the page size is user-defined, Microsoft Access reads the settings
that you specified for that printer driver with the Printers utility in
Control Panel. If your report page exceeds this user-defined paper size,
your report will include blank pages.
A new page size will not be available in Microsoft Access until you
set one up in the Printers utility in Control Panel.
The following steps describe how to change the page size with the
Printers utility:
NOTE: Only dot-matrix printer drivers have a user-definable page
option. Laser printer drivers do not.
1. Open Control Panel, usually found in the Main program group of
Microsoft Windows Program Manager.
2. Double-click the Printers icon to start the Printers utility.
3. Select the printer driver you want to change and then choose the
Setup button.
4. In the Paper Size box, select User-Defined. A dialog box is
displayed in which you can adjust the settings.
- When you are using the Groups/Totals Report Wizard, select the "Fit All
Fields On One Page" check box on the last screen before you switch to
Design view or print or preview the report. After you select this check
box, the Report Wizard assumes a page 8.5 inches wide, then sizes the
fields and controls accordingly. If the check box is cleared, the
resulting report width may exceed the page size.
- The Same As Detail option is useful when you create a detailed,
multiple-column report and want the detail section to be a different
size than the other sections. Clearing this check box can cause blank
pages if the width defined for the detail section of the report is
greater than the page size specified. This box, found under Item Size in
the Print Setup dialog box, is selected by default. The Width property
is set to match the report's Width property.
STATUS
This behavior is by design.
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