The information in this article applies to:
- Internet Client SDK, versions 4.0, 4.01
- Microsoft Internet Explorer (Programming), versions 4.0, 4.01
SYMPTOMS
Despite the fact that <USAGE VALUE="Email"> has been specified for a parent
ITEM element in a CDF file, the subscribed user never receives the e-mail
when a content update occurs.
CAUSE
Two things may cause this problem to occur: either the user did not
specifically ask to receive e-mail notifications for content update when he
or she subscribed to the channel, or the SMTP server was not specified
correctly.
RESOLUTION
In order for channel email notifications to get sent, all three conditions
have to be met:
- Specify <USAGE VALUE="Email"> in your CDF file, as in this example:
<CHANNEL HREF="http://example.microsoft.com">
<ITEM HREF="http://example.microsoft.com/emailthis.htm>
<USAGE VALUE="Email" />
</ITEM>
</CHANNEL>
- When subscribing to the channel, click the Customize button
and select YES when asked if you want to be notified in an e-mail
message when the page has changed. (This was added as a pre-requisite
to receiving e-mail in response to user complaints about receiving
unwanted e-mail from sites they subscribed to. Therefore, unless the
user chooses to be notified, no e-mail will be sent.)
- When prompted for an e-mail address, click the Change Address button and
specify the right SMTP server name. If you do not know, ask your ISP
(Internet Service Provider) what server name to specify.
STATUS
This behavior is by design.
MORE INFORMATION
If all three conditions above are met, an e-mail notification is sent to
the subscribed user in this format:
Subject: Internet Explorer Notice: <web site title>
Message: <site URL> Your subscription to <web site title> has been
updated.
To view the subscription offline, click here: <site URL>
This message was sent by the Internet Explorer
4.0
Information Delivery Agent.
If your e-mail client is HTML-aware, then the e-mail received is the actual
Web page specified in the <ITEM> tag in the CDF file.
Steps to Reproduce Behavior
- Create a simple .cdf file with the following text. Save the file as
Simple.CDF, and make it available on your HTTP server:
<channel HREF="http://<server name>/test.htm">
<ITEM HREF="http://<server name>/mailme.htm">
<USAGE VALUE="Email" />
</ITEM>
</channel>
- Run Simple.CDF through Xmlint.exe and Cdftest.exe (available in
the Internet Client SDK under \inetsdk\bin\XMLint and
\inetsdk\bin\cdftest, respectively).
Verify that no errors are found in your .CDF file.
- Subscribe to http://<your server name>/simple.cdf.
- From the "Add Channel" wizard, click the Customize button, and when
asked if you would like to get notified in an e-mail message when the
page changes, select YES, click on the "Change Address" button and
specify the correct e-mail address and SMTP server name to be used.
Click the Finish button, and click OK to exit the Channel wizard.
- The page you just subscribed to should come up full-screen in a channel
window. (In the example above, Test.htm comes up full-screen.)
- Modify the .cdf file to simulate a content update.
- From the desktop channel bar, right-click on your newly added
Simple.cdf channel, and select Update Now. This should cause your
files to get downloaded again. And if changes were detected, should
display a red gleam on the upper left hand corner of your channel logo.
Or from Manage Subscriptions, right-click on your page, and choose
Update Now. Verify that changes were detected, with the gleam on your
icon, and Status set to "Updated."
Note that if any of the HTMs specified as <ITEM> tags in the CDF are
modified in step 6 above, instead of the CDF file, no changes are
detected (that is, Status set to "Updated: No changes detected"), and
therefore no gleam is displayed.
- If new content is found, and assuming you specified the correct e-mail
address and SMTP name, you should get an e-mail notification in your
mailbox.
The information in this article also applies to e-mail notifications being
sent when a user subscribes to a favorite site directly (that is, from
Internet Explorer, navigating to your favorite site, and from the menu,
choosing to Add to Favorites). The only time an e-mail notification is sent
is if the user specifically clicks on the Customize button and asks to get
notified in e-mail when content is updated.
To subscribe to a Web page directly:
- Navigate to the page (preferably one you can change, so that you'll be
able to see how when the page is updated, you get notified).
- Select Favorites/Add to Favorites. Choose to Subscribe to the page,
either to tell you when page is updated, or to download the page for
offline viewing.
- Click on Customize and when prompted to receive notifications via e-
mail, say Yes, and click on Change Address button and specify an e-mail
address and SMTP names correctly. These are important to specify here.
Otherwise, no e-mail will be received.
- Click Finish, and click OK out of the Add Favorites wizard.
- Now make a change to the .htm page you just subscribed to.
- From Internet Explorer's Favorites menu, select Manage subscriptions.
Select the site you subscribed to from the list, right-click on it and
choose to "Update now."
- Verify that your changes were detected by noticing a gleam on the upper-
left hand corner of the icon next to your page name on the Manage
Subscriptions list, and Status set to "Site changed."
- Check your e-mail client and look for a mail message with subject line
"Internet Explorer Notice: <site URL>"...same as above
REFERENCES
Internet Client SDK documentation
Keywords : AXSDKMisc InetSDKInfoDev
Technology : kbInetDev
Version : WINDOWS:4.0,4.01
Platform : WINDOWS
Issue type : kbprb
|