XL: Cannot Rename to '<File name>' Saving to Network Drive

Last reviewed: February 20, 1998
Article ID: Q113600
The information in this article applies to:
  • Microsoft Excel for Windows, versions 5.0, 5.0c
  • Microsoft Excel for Windows 95, versions 7.0, 7.0a
  • Microsoft Excel 97 for Windows

SYMPTOMS

In Microsoft Excel, when you save a workbook file on a network drive, if you do not have both Modify and Delete rights for the directory to which you are saving the file, one of the following occurs:

  • When you save a new workbook file to the network drive, you receive the following error message

          Microsoft Excel versions 5.0, 7.0
          ---------------------------------
    

          Document saved as '4CCA4100'. Cannot rename to 'BOOK1.XLS'. You must
          close this document.
    

          Microsoft Excel 97
          ------------------
    

          Your changes could not be saved to 'BOOK1.XLS', but were saved to
          '4CCA4100'. Close the existing document, then open the temporary
          document and save it under a new name.
    

    where 4CCA4100 is an eight-character alphanumeric string, and BOOK1.XLS is the name of the file being saved.

    -or-

  • When you save an existing workbook file to the network drive, the file appears to be saved with the name you entered in the Save dialog box. However, when you open this file again from the network, your changes do not appear in the file. The file is actually saved to the network drive with a filename that contains numbers and letters, such as 4CCA4100.

CAUSE

The message occurs because Microsoft Excel writes a temporary file to the location that the file is being saved to and then renames the temporary file to the name of the file being saved, such as BOOK1.XLS.

When you save a workbook file in Microsoft Excel, a backup copy of the original file is created that contains the changes you made to the file. This file is then saved over the original file. If the original file cannot be deleted, or the backup file cannot be renamed, the backup copy (file that contains your changes) is saved with a filename that contains a combination of numbers and letters, such as CEDD4100. Note that the filename does not have an extension.

You only receive an error message that contains the filename that your file is saved to if you are saving a workbook that has not been saved before. This is only a problem when you save a file to the Microsoft Excel Workbook or Template format.

WORKAROUND

To avoid this behavior, do one or more of the following:

  • Notify your network administrator that you do not have Delete rights for this directory on the network drive. You must have Modify and Delete rights in order to save a Microsoft Excel workbook file with the correct filename to this directory.

    -or-

  • Save your workbook files to your local hard drive, or to a directory for which you do have Modify and Delete rights. You may then be able to copy the file to the network drive on which you do not have Modify or Delete rights.

    -or-

  • If you have an antivirus program installed either on your computer or on the network server, uninstall the antivirus program, and see if the problem still occurs. Some antivirus programs may interfere with the save process in Microsoft Excel.

    NOTE: In some cases, it may only be necessary to disable the antivirus program. If disabling the antivirus program does not work, you may need to actually uninstall the antivirus program.

    NOTE: You may want to check with the maker of your antivirus program to see if an updated version that addresses the save problem in Microsoft Excel.

MORE INFORMATION

To verify that you do not have the rights on the network to modify or delete a file, try renaming or deleting the file on the network drive from File Manager. If you cannot rename or delete the file from File Manager, you are not able to save a file to this drive from Microsoft Excel.


Additional query words: 5.00 5.00c 7.00 7.00a 97 XL97 XL7 XL5 err msg
novell novel privilege macafee f-prot ibm norton fprot
Keywords : kbnetwork kbusage
Version : 5.00
Platform : WINDOWS


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 20, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.