XL97: Not all Menu Items Appear for Other Users

Last reviewed: March 13, 1998
Article ID: Q157768
The information in this article applies to:
  • Microsoft Excel 97 for Windows
  • Microsoft Windows NT, versions 3.51, 4.0

SYMPTOMS

When you start Microsoft Excel 97, some menu items are not displayed.

CAUSE

This may occur if the following conditions are true:

  • You are not logged on the computer as the user who originally installed Microsoft Excel 97 (either as an individual program or or as part of Microsoft Office 97) on this computer.

        -and-
    
  • The computer is running Windows NT, version 3.51 or 4.0, or it is running Windows 95 with User Profiles turned on.

For example, if user "JoeTech" installs Microsoft Excel 97 on this computer and you log on as user "JaneTech", certain menu items, such as "Save as HTML" (on the File menu) and "Report Manager" (on the View menu), may not appear.

WORKAROUND

To add menu items, you must activate the add-ins that provide the missing menu items. To do this:

  1. On the Tools menu, click Add-Ins.

  2. In the list of available Add-Ins, select the check box to the left of each add-in whose menu item is not displayed:

                                       Menu                 Sub Menu
    Add-In                     Menu    Item                 Item
    

AccessLinks Add-In         Data    MS Access Form
                           Data    MS Access Report
                           Data    Convert to MS Access
Analysis ToolPak           Tools   Data Analysis
AutoSave                   Tools   AutoSave
Bookshelf Integration      Tools   Look Up Reference
Conditional Sum Wizard     Tools   Wizard               Conditional Sum
File Conversion Wizard     Tools   Wizard               File Conversion
Internet Assistant Wizard  File    Save as HTML
Lookup Wizard              Tools   Wizard               Lookup
Report Manager             View    Report Manager
Solver Add-In              Tools   Solver
Template Wizard with       Data    Template Wizard
   Data Tracking
Web Form Wizard            Tools   Wizard               Web Form

  • Once the add-ins are selected, click OK to close the dialog box.

    Each user who logs on this computer may need to repeat these steps the first time they log on and use Microsoft Excel.

    STATUS

    This behavior is by design of Microsoft Excel 97.

    MORE INFORMATION

    When you install Microsoft Excel 97 on your computer, if you choose to install any add-ins, they are copied onto your computer and are available for everyone to use.

    However, if your computer is running Windows NT or is configured to use User Profiles under Windows 95, Microsoft Excel 97 stores add-in settings for each user separately. Because of this, only the user who installed Microsoft Excel 97 will have add-ins turned on by default. Other users who log in to the computer and run Microsoft Excel 97 may find that not all add- ins are turned on.

    For example: if user "JoeTech" installs Microsoft Excel 97 and chooses to install add-ins, the Setup program will copy the add-ins onto the computer and turn on the add-ins for JoeTech. If user "JaneTech" logs on the computer, she initially has no settings for Microsoft Excel 97. So, when she first runs Microsoft Excel 97, not all of the add-ins will load.

    Follow the steps shown in the workaround section to eliminate this problem for the current user.

    To turn User Profiles on in Windows 95:

    1. On the Start menu, point to Settings and click Control Panel.

    2. Double-click Passwords. Click the User Profiles tab.

    3. Click "Users can customize...". Select both check boxes. Click OK.


  • Additional query words: XL97 8.00
    Keywords : xladdins xlui xlwinsetup kbsetup kbfaq
    Version : WINDOWS:97
    Platform : WINDOWS
    Issue type : kbprb


    THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

    Last reviewed: March 13, 1998
    © 1998 Microsoft Corporation. All rights reserved. Terms of Use.