XL: Error Sending Workbook to Mail Program

Last reviewed: January 9, 1998
Article ID: Q168755
The information in this article applies to:
  • Microsoft Excel 97 for Windows
  • Microsoft Excel for Windows 95, versions 7.0, 7.0a
  • Microsoft Excel for Windows, versions 5.0, 5.0c

SYMPTOMS

When you attempt to send a workbook to a Mail Recipient in any of the versions of Microsoft Excel listed at the beginning of this article, you may receive the following error messages:

   Microsoft Exchange
   A dialog box is open. Close it and try again.

   -and-

   Microsoft Excel
   General mail failure. Quit Microsoft Excel, restart the mail system,
   and try again.

CAUSE

This problem occurs if a dialog box, such as the Select Names dialog box, is being displayed by your mail program when you attempt to send the workbook from Microsoft Excel.

RESOLUTION

To prevent this problem from occurring, switch to your mail program and close the dialog box by clicking OK or Cancel. Then, in Microsoft Excel 97, on the File menu, point to Send To, and click Mail Recipient. In earlier versions of Microsoft Excel, click Send on the File menu.

STATUS

This behavior is by design of Microsoft mail programs such as Microsoft Exchange and Microsoft Outlook 97.

MORE INFORMATION

In both Microsoft Exchange and Microsoft Outlook 97, many of the dialog boxes used by the program are modal: that is, as long as the dialog box is visible on the screen, the program cannot perform any other actions.

Because of this, if a dialog box is visible in your mail program, when Microsoft Excel requests that the mail program create a new mail message, the mail program is unable to comply. As a result, you receive the error messages mentioned in the "Symptoms" section.

Once you close the dialog box in your mail program, if you are still unable to send a workbook from Microsoft Excel, you may need to quit Microsoft Excel, restart your mail program, and try again.


Additional query words: XL5 XL7 XL97 mapi microsoft mail
Keywords : xlui kberrmsg
Version : WINDOWS:5.0,5.0c,7.0,7.0a,97
Platform : WINDOWS
Issue type : kbprb
Solution Type : Info_Provided


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: January 9, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.