XL97: Diagonal Gradient Fill May Not Be Printed Correctly

Last reviewed: January 7, 1998
Article ID: Q174239
The information in this article applies to:
  • Microsoft Excel 97 for Windows
  • Microsoft Windows 95

SYMPTOMS

When you print a worksheet in Microsoft Excel 97, drawing objects and AutoShapes that are filled with a diagonal gradient fill may be printed incorrectly. Specifically, the gradient fill may "bleed," or appear outside of the drawing object or AutoShape.

CAUSE

This problem may occur when the following conditions are true:

  • You are printing to a non-PostScript printer that uses Printer Command Language version 5.0 (PCL5). These printers include the following:

          Hewlett-Packard LaserJet 4M
          Hewlett-Packard LaserJet 5Si
          Lexmark LaserPrinter 4039
    

        -and-
    
  • You are using Microsoft Windows 95.

        -and-
    
  • The printer driver is configured to print in vector mode.

Note that this problem does not occur when you print to PostScript printers, when you print to printers that do not use PCL5, or when you print an object that is filled with a nondiagonal gradient fill.

WORKAROUND

You can work around this problem by changing the default print mode to raster mode. To do this, follow these steps:

  1. Save your work and quit any running programs.

  2. On the Start menu, point to Settings, and click Printers.

  3. In the list of printers, right-click the printer driver for the printer. On the shortcut menu, click Properties.

  4. Click the Graphics tab.

  5. Click Use Raster Graphics.

  6. Click OK.

To print a single document in raster mode, follow these steps:

  1. Switch to the document that you want to print.

  2. On the File menu, click Print. Then, click Properties.

  3. Click the Graphics tab.

  4. Click Use Raster Graphics.

  5. Click OK. Then, click OK again to print the document.

Note that if you print in raster mode, text or other objects behind the AutoShape may appear through the AutoShape. For this reason, do not use this workaround if text or other objects are behind the AutoShape.

Note that you may also be able to prevent this problem from occurring by installing a newer version of the printer driver for your printer if one is available. To determine whether a driver is available, contact the printer manufacturer.

STATUS

This problem occurs when you use Microsoft Excel 97 and you print objects that are filled with a diagonal gradient fill to a printer that uses PCL5.

MORE INFORMATION

In Microsoft Excel 97, you can fill a drawing object or AutoShape with a gradient fill. To do this, follow these steps:

  1. Click to select the object. On the Format menu, click Object or AutoShape.

  2. Click the Colors And Lines tab. Under the Fill section, click Fill Effects in the Color box.

  3. Click the Gradient tab.

  4. Under Colors, click one or two colors. Under Shading Styles, click one of the six options (Horizontal, Vertical, Diagonal Up, Diagonal Down, From Corner, or From Center). When you are done, click OK.

  5. Click OK again.

The AutoShape is filled with a gradient fill.

If you fill an AutoShape with diagonal fill, the problem described in the "Symptoms" section in this article may occur when you print the worksheet or chart that contains the AutoShape. The workaround in this article may prevent the problem from occurring; however, it may cause another problem if text or another object is behind the AutoShape.

For more information about printing problems in Microsoft Excel 97, please see the following article in the Microsoft Knowledge Base:

   ARTICLE-ID: Q159227
   TITLE     : XL97: Drawing Objects and AutoShapes Printed Incorrectly


Additional query words: XL97
Keywords : xldraw xlformat xlprint kbprint
Version : WINDOWS:97
Platform : WINDOWS
Issue type : kbbug
Solution Type : kbworkaround


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: January 7, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.