The information in this article applies to:
- Microsoft Exchange Server, version 4.0
SYMPTOMS
If the computer running Microsoft Exchange Server stops responding or was
not shut down gracefully after stopping all the services properly, the
following error message may be displayed on screen and in the event logs:
Error -550 has occurred
This message may also appear in the Directory or Information Store
database, in the case of a power failure.
CAUSE
This error usually means that the database is in an inconsistent state and
cannot start.
RESOLUTION
Confirm that the state of the database is inconsistent, and then try a
defragmentation repair. Be sure to stop all services and backup all files
before you run the Edbutil.exe program.
- To check the state of the database, use Edbutil.exe with the "MH" option
on the problem database and dump the output to a text file:
EDBUTIL /MH c:\exchsrvr\dsadata\dir.edb >c:\edbdump.txt
-OR-
EDBUTIL /MH c:\exchsrvr\mdbdata\priv.edb >c:\edbdump.txt
-OR-
EDBUTIL /MH c:\exchsrvr\mdbdata\pub.edb >c:\edbdump.txt
- Edit the Edbdump.txt file and confirm that the state of the database is
inconsistent. If the database is in an inconsistent state, run the
Edbutil.exe utility against the database. You must complete a full
backup of the Microsoft Exchange Server Directory and Information Stores
before you use the Edbutil utility.
- To repair the database, use the following Edbutil syntax
EDBUTIL /R /DS
where D=Defragmentation and R=Repair database.
Use /ISPRIV or /ISPUB instead of /DS for repairing the private or public
Information Stores. There is a difference between the Repair(/d
[database]/r) database while defragmenting and Recovery(/r) option of
EDBUTIL.
- After repairing the database, move the Edb.chk file out of the
Exchsrvr\Dsadata directory (in case of Directory database repair) or
from the Exchsrvr\Mdbdata directory if you are repairing the
Information Store. Now try to restart the services; this will create a
new Edb.chk file.
If the above does not work (the service does not start), the LOG files
may have a problem. When the service tries to start up, if it was not
stopped gracefully, it reads the LOG files. Try moving all files from
Exchsrvr\Dsadata directory except for Dir.edb or from the
Exchsrvr\Mdbdat directory except for Priv.edb and Pub.edb to a Temp
directory. Now try to restart the services; the new log files will get re-
created upon startup.
The EDB-HexId.log files that were moved to the Temp directory are required
for incremental backups. If you are able to start the service successfully,
move these back to the original database directory.
If you are having further problems and the service still returns the error
above, please contact your primary support provider.