XCLN: Update Not Updating Files in Directories w/Long File Names

Last reviewed: April 7, 1997
Article ID: Q155885
The information in this article applies to:
  • Microsoft Exchange Windows 95 Client, version 4.0
  • Microsoft Schedule+, version 7.0

SYMPTOMS

When running Update.exe for Microsoft Exchange Server Service Pack 3 on a client computer running Windows 95, some files are not updated. Update.exe runs without an error, and states that Setup was completed successfully.

The following are the affected files:

   Msspc32.dll
   Scanpst.exe
   Newprof.exe
   Exchng32.exe
   Mlshext.dll

CAUSE

The update program uses the 16-bit version of the API to locate and read the directory names. This version of the API does not support long file names, and the process cannot find the files to be updated (that is, C:\Program Files\Microsoft Exchange\Exchng32.exe) so they are never copied over the older versions.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 4.0. This problem was corrected in the latest Microsoft Exchange 4.0 U.S. Service Pack. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K


Additional query words: gone missing disappear vanished
Keywords : kbbug4.00 kbfix4.00.sp4 XCLN kbusage
Version : 4.0
Platform : WINDOWS
Issue type : kbbug
Solution Type : kbfix


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Last reviewed: April 7, 1997
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