XCLN: Troubleshooting Windows Client over Internet

Last reviewed: February 3, 1998
Article ID: Q161489
The information in this article applies to:
  • Microsoft Exchange Windows 3.x client, version 4.0
  • Microsoft Exchange Windows NT client, version 4.0
  • Microsoft Exchange Windows 95 client, version 4.0

SYMPTOMS

When the Microsoft Exchange client is connecting over the Internet, you receive a message that says "server cannot be found."

CAUSE

Due to firewalls or name resolution issues, the client is unable to attach to Microsoft Exchange Server.

WORKAROUND

To resolve this problem, you need to work on both the client and the server:

On the computer running Microsoft Exchange Server:

  1. Check the "Services" file in <Windows>\System32\Drivers\etc. This will show the port numbers currently in use.

  2. If you are using a packet filter, you can force Microsoft Exchange Server to use a fixed port for remote procedure calls (RPC). To do this:

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows NT. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

   a. Start Registry Editor (Regedt32.exe).

   b. Under the HKEY_LOCAL_MACHINE subtree, go to the following subkey:

         SYSTEM\CurrentControlSet\Services\MSExchangeDS\Parameters

   c. Create a REG_DWORD registry entry called "TCP/IP port." The value is
      "decimal" <port number>. You must also configure the port number in
      your packet filter.

   NOTE: The <Port Number> may be any number over 1024 and must be in 
   decimal format. In addition, the DS and IS Port Number must be different.

   EXAMPLE: "TCP/IP Port"=dword:00000400(1024)

   The number 1024 for the DS above is 400 in hexidecimal format.

   d. For the Information Store, create a registry entry called "TCP/IP
      port" under the following key:

         HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
                           \MSExchangeIS\ParametersSystem\

     This is a DWORD and the value is "decimal" <port number>.

     NOTE: The <Port Number> may be any number over 1024 and must be in 
     decimal format. In addition, the DS and IS Port Number must be 
     different.

     EXAMPLE: "TCP/IP Port"=dword:00000402(1026)

        The number used was 1026 for the IS, 402 in hexidecimal format.

   e. Add a registry entry called "TcpipClientSupport" under the following
      key:

         HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/LSA

      This is a DWORD; set it to Hex 1.

  • Quit Registry Editor.

  • Configure your packet filter to allow TCP connections to the ports mentioned above plus port 135 (for the RPC End-Point Mapper service) on the Microsoft Exchange Server-based server.

    On the client:

    1. Edit the Lmhosts file to have an entry for the computer running Microsoft Exchange Server. For example:

            tcp/ip address  servername  #PRE  #DOM:domain name
            200.246.248.29  enterprise  #PRE  #DOM:training
      

    2. Edit the Hosts file to have an entry for the computer running Microsoft Exchange Server. For example:

            ipaddress  <complete internet host name>
            200.246.248.29 enterprise.sao.nutecnet.com
      

    3. On the Tools menu, click Services, click Exchange Server, click Properties, and click Advanced. Clear the "use network security" check box.

    4. Make sure TCP/IP is first in the Exchange binding order. This procedure varies for the different Windows clients:

      For 32-bit clients (Windows 95 clients and Windows NT clients):

    WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows NT. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

       a. Start Registry Editor (Regedt32.exe).
    
       b. Under the HKEY_LOCAL_MACHINE subtree, go to the following subkey:
    
             SOFTWARE/Microsoft/Exchange/Exchange Service Provider
    
       c. Make sure the RPCBindingOrder value has ncacn_ip_tcp listed first.
    
       d. Quit Registry Editor.
    
       For 16-bit clients (Windows 3.x clients):
    
       a. Open Exchng.ini (in the Windows directory).
    
       b. In the [Exchange Provider] section, make sure
          Rpc_Binding_order=ncacn_ip_tcp.
    
    

    REFERENCE

    For additional information, please see the following articles in the Microsoft Knowledge Base:

       ARTICLE-ID: Q149692
       TITLE     : XCLN: Error Message When Clients Try to Connect via Internet
    
       ARTICLE-ID: Q152725
       TITLE     : XCLN: How to Connect over the Internet to an Exchange Server
    
    
    Also see http://www.microsoft.com/exchange/guide/papers/connecttointernet.asp


  • Additional query words: kbfaq
    Keywords : XCLN kbusage
    Version : 4.0
    Platform : WINDOWS


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    Last reviewed: February 3, 1998
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