XADM: Err Msg: Unable to Recover the Database Because Error

Last reviewed: December 29, 1997
Article ID: Q161584
The information in this article applies to:
  • Microsoft Exchange Server versions 4.0 and 5.0
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

SYMPTOMS

When you try to start the Microsoft Exchange Information Store service, the following error occurs:

   The Microsoft Exchange Information Store service returned
   service specific error 3355445011

In the Windows NT Event Log, the following entry may be present:

   Event ID: 1080
   Source: MSExchangeIS
   Type: Error
   Category: Recovery
   Description: Unable to recover the database because error 0xc8000713
   occurred after a restore operation. Unable to find the file.

CAUSE

The above error message occurs when the information store appears to be restored from an online backup, but the information store files are not restored because they are damaged or missing. After a restore operation the Restore in Progress registry key is added to the following key:

   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS

When the Information Store service starts and finds the above registry key, it assumes a restoration has occurred and that the information store needs to perform recovery steps. The information store then attempts to move forward through any log files. Once the information store has successfully started, this registry key is deleted. However, if the information store cannot find the Priv.edb file or Pub.edb file, it cannot move forward through the log files, and the above error message occurs. In this case, the information store does not create blank EDB files, and the registry key is not deleted.

RESOLUTION

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it.

To resolve the problem above, delete the Restore in Progress key from the Registry Editor in the following location:

   HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS

Start the information store again. If the required EDB files are not found, they will be re-created. After this is done, try restoring from backup again.
Keywords          : XADM kbusage
Version           : WINDOWS:4.0,5.0
Platform          : WINDOWS
Solution Type     : kbworkaround


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: December 29, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.