XCLN: Troubleshooting IPX/SPX Connections

Last reviewed: February 3, 1998
Article ID: Q161626
The information in this article applies to:
  • Microsoft Exchange Windows 3.x client, versions 4.0 and 5.0
  • Microsoft Exchange Windows NT client, versions 4.0 and 5.0
  • Microsoft Exchange Windows 95 client, versions 4.0 and 5.0

SYMPTOMS

The client cannot connect to a computer running Microsoft Exchange Server using IPX/SPX. Remote procedure call (RPC) pings work, but not with security. In addition, you may receive the following error:

   Your Microsoft Exchange Server is unavailable.

CAUSE

The IPX/SPX protocol is not configured correctly for Microsoft Exchange Server access.

RESOLUTION

The following is a checklist you can use to ensure that the IPX/SPX protocol is correctly configured:

  1. Make sure IPX/SPX (NWLINK) is installed on the computer running Microsoft Exchange Server, the computer running the Microsoft Exchange client, and any primary or backup domain controllers.

  2. Gateway Services for NetWare (GSNW) or File and Print Services for NetWare (FPNW) must be installed and running on the computer running Windows NT Server and Microsoft Exchange Server.

    If the client's "primary login" is "Microsoft Network", then FPNW must be installed and configured.

    If the client's "primary login" is "Novell Network", then GSNW must be installed and configured.

  3. Make sure the SAP service is running on the computer running Windows NT Server and Microsoft Exchange Server (it should be installed with GSNW or FPNW).

  4. If NetWare is the primary network logon, make sure GSNW is installed, running, and has a Preferred Server on the computer running Windows NT Server and Microsoft Exchange Server (in the GSNW Control Panel, change preferred server from <none> to the appropriate Novell Server).

  5. Check IPX/SPX frame types. It is recommended that you manually set this on both the computer running Microsoft Exchange Server and its clients. (On the computer running Windows NT Server, go to the Network Control Panel and click IPX/SPX. Click Properties, click to check "Manual Frame Type Detection" and add the appropriate frame type, such as 802.3.)

  6. If "Manual Frame Type Detection" is selected, make sure the network number is unique for every server on the network.

  7. Make sure the packet size is the same on Token ring, or a smaller size on Ethernet. In the Net.cfg file on computers running Windows for Workgroups or Windows 3.1, make sure MaxFrameSize equals an appropriate size, such as 1,496. On client computers running Windows 95, go to the Network Control Panel, click IPX/SPX, and then click Properties. Click Advanced, and set "Force Even Length Packets" to yes. Client computers running Windows 95 or Windows NT Workstation should adjust the frame size to their primary logon server. On Token ring, if the primary logon server is Novell or another computer running Windows NT Server, make sure the computer running Microsoft Exchange Server or Windows NT Server is set to the same Packet Size.

  8. On computers running Windows for Workgroups or Windows 3.1, open the Net.cfg (or Shell.cfg) file and make sure IPX packets=50, IPX Sockets=50, and READ ONLY COMPATIBILITY=OFF. In the [NETWORK] section of the System.ini file, set Directhost=OFF.

If you have verified that IPX is configured correctly, you can use the following steps for additional troubleshooting:

  1. Run Rpings.exe on the server. Make sure there are valid endpoints (set for use) for ncadg_ipx and ncacn_spx.

  2. Run Rpingc32.exe on client computers running Windows 95 or Windows NT Workstation, to make sure IPX/SPX can complete an RPC "ping" to the server. Also try this "with security."

  3. On the client, try logging in without using default network security. (On the Tools menu, click Services. Select Microsoft Exchange Server, click Properties, and then click Advanced. Click to clear the check from "use network security during logon.") This forces a prompt to appear for the user to enter Windows NT Server domain, account, and password information.

  4. Update the IPX/SPX drivers. The latest version, as of 11/96, is VLM 1.21 and is available on http://www.novell.com. Search for VLM Client Kit for Dos/MS Windows v1.21.

    NOTE: Many old VLM NetWare drivers will not connect to Microsoft Exchange Server. On computers running Windows for Workgroups 3.11 or Windows 3.1, you may need updated versions of Nwipxspx.dll and Nwcalls.dll.

  5. Move ncacn_spx to be first in the binding order. Reboot.

  6. If there is a Microsoft Proxy Server installed on the network, try turning off DNS. (In the Network Control Panel, select TCP/IP and click Properties. Click the DNS Configuration tab, and click Disable DNS.) You can keep the TCP/IP functionality by adding to the hosts file. In the hosts file, make one entry for the Microsoft Exchange Server as <IP address> <Microsoft Exchange Server Name, or NetBIOS name>, and one for the Proxy Server as <IP Address> <proxy server fully qualified domain name, such as server.company.com>.

  7. Check the Event Viewer on the computers running Windows NT Server (the computers running Microsoft Exchange Server, the PDC, or the BDC servers) for errors.

  8. Check the network settings to make sure that there are no compression settings on the network routers. If so, try removing compression on the routers. (If compression on routers is an issue, contact the router manufacturer to see if there are any known issues with Windows NT Server.)

  9. Make sure IPX/SPX is routable on the network.

MORE INFORMATION

For more information, see the following article in the Microsoft Knowledge Base, the Microsoft Exchange Installation Guide - the Introduction and Appendix A, and the Readme.wri file on the Microsoft Exchange Client Software compact disc:

   ARTICLE-ID: Q136516
   TITLE     : XCLN: Improving Windows Client Startup Times


Additional query words: kbfaq
Keywords : XCLN kbnetwork kbusage
Version : 4.0 5.0
Platform : WINDOWS


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Last reviewed: February 3, 1998
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