The information in this article applies to:
- Microsoft Exchange Windows NT client, version 4.0
- Microsoft Exchange Windows 95 client, version 4.0
IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, make sure you understand how to restore it
if a problem occurs. For information on how to do this, view the "Restoring
the Registry" online Help topic in Regedit.exe or the "Restoring a Registry
Key" online Help topic in Regedt32.exe.
SYMPTOMS
When you attempt to remove Microsoft Exchange Client by clicking the
Add/Remove in Control Panel or clicking Add/Remove in Exchange Client
Setup, Exchange Client does not seem to be removed.
CAUSE
Several registry keys and files remain.
WORKAROUND
To remove Microsoft Exchange Windows 95 and Windows NT clients from a
computer that does not also have Microsoft Exchange Server installed on it,
follow these steps:
WARNING: Using Registry Editor incorrectly can cause serious problems that
may require you to reinstall Windows. Microsoft cannot guarantee that
problems resulting from the incorrect use of Registry Editor can be
solved. Use Registry Editor at your own risk.
For information about how to edit the registry, view the "Changing Keys And
Values" online Help topic in Registry Editor (Regedit.exe) or the "Add and
Delete Information in the Registry" and "Edit Registry Data" online Help
topics in Regedt32.exe. Note that you should back up the registry before
you edit it.
- If you plan to reinstall the client later, synchronize any .ost files,
and back up any .pst and .pab files. (This assumes there is no
corruption in the files.)
NOTE: Backing up .ost files will not work. That information will NOT be
recoverable! Only a synchronization with the Exchange Server Mailbox will
ensure there is no loss of information.
- Log out of any applications.
- Back up the entire client computer. (Later, registry keys will be
removed. Full backup is required unless recovery does not matter.)
- In Control Panel, click Add/Remove Software. Remove any Exchange and
messaging options.
- Go to the latest exchange Setup and click Remove All. ("Latest" Setup
means the highest version installed on this computer.)
- Start Registry Editor.
- Go to the following key in the registry:
HKEY_LOCAL_ MACHINE\Software\Microsoft...
- Delete the Exchange and Windows Messaging folders and subkeys.
- Exit Registry Editor.
- Do a search on *exch* and remove all remaining files.
- Remove the <system root>\<windows>\system32\Msremind.wav file.
- Restart the computer.
To reinstall Exchange Client:
- Rename the Mapi.dll, Mapi32.dll, and Mfcans32.dll to *.old. These files
are usually located in the <system root>\<windows>\system32\ directory.
- Restart the computer.
- Reinstall Exchange Client.
- You can point the client to the "old" .pab and .pst files. However, if
you are reinstalling due to corruption issues, it's best to test the
client with new files. Then, import the old information into the new
files. ( On the File menu, click Import, and then click .pab and so on.)
- If all is OK, remove the Mapi.old and Mapi32.old files (renamed in the
step 1 above).
To remove a Microsoft Exchange Windows NT client from a computer that also
has Microsoft Exchange Server installed, follow these steps:
- In Control Panel Services, stop System Attendant.
- In Control Panel Add/Remove Programs, select Microsoft Exchange and then
click Add/Remove.
- Click Remove All.
- When asked if you want to remove all shared components, click KEEP.
- Once Setup is done, rename the Exchange directory where Exchange Client
was installed.
- Start Registry Editor . Export the the following keys and then delete
them:
NOTE: Make sure you export the keys prior to deleting them, in case
of error.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\Client
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\Forms Registry
Delete the following String Value:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\Exchange Provider
"Rpc_Binding_Order"
Restart the computer.
To reinstall Exchange Client on the computer running Exchange Server:
- In Control Panel Services, stop System Attendant.
- Reinstall Exchange Client.
- Restart computer and make sure all Exchange Server Services and the
Exchange Client function properly.
Keywords : kbbug4.00 XCLN kbsetup kbtshoot
Version : WinNT:4.0;Win95:4.0
Platform : Win95 winnt
Issue type : kbbug
Solution Type : kbworkaround