The information in this article applies to:
- Microsoft Exchange Server versions 4.0 and 5.0
SYMPTOMS
The Internet Mail Service (or Internet Mail Connector, in version 4.0)
stops responding and cannot be restarted. If you attempt to start it
manually or run the Internet Mail Wizard, one of the following events
appears in the event viewer's application log:
- Event ID: 4037
Type: Error
Source: MSExchangeIMC
Category: Internal Processing
Description: An exception has occurred which was handled internally by
the Internet Mail Connector. This may have resulted in a message not
being delivered.
- Event ID: 4037
Type: Error
Source: MSExchangeIMC
Category: Internal Processing
Description: An exception has occurred which was handled internally by
the Internet Mail Service. This may have resulted in a message not being
delivered.
If you are attempting to start the Internet Mail Connector, the following
error message is also displayed:
Could not start the Microsoft Exchange Internet Mail Connector service
on \\<servername>.
Error 1067: The process terminated unexpectedly.
If you attempt to stop the Internet Mail Service, you will find that the
Stop button is unavailable.
CAUSE
This problem may result from a corrupt message in the Exchange Server
directory (Imcdata\in or IMCdata\out folders). Resolving this condition is
the subject of this article.
The same error and symptom may result from a corrupted message in the MTA
store. For more information, see below under More Information.
RESOLUTION
To resolve this problem:
- Stop the Internet Mail Service using Kill.exe or Tlist from the Windows
NT Resource Kit or BackOffice Resource Kit. The IMC service should show
up as stopped in the Control Panel Services.
- Create two sub-directories called temp under Imcdata\In and Imcdata\Out
- Move all the files from Imcdata\in to Imcdata\in\temp and from
Imcdata\out to Imcdata\out\temp.
- Delete the file Imcdata\queue.dat.
- Restart the Internet Mail Service. If it starts and stays on, test the
normal operation, and then move to step 7.
- If the IMC stops again, the corrupt message is not in the directory, but
rather in the MTA store, and you have to follow the steps in the
articles referenced in the More Information section below.
- Move 50 percent of the messages from Imcdata\in\temp to Imcdata\in
and\or from Imcdata\out\temp to Imcdata\out. Delete Queue.dat, and then
stop the Internet Mail Service and restart it. If this process is
successful, repeat it until you find the bad message(s) and move all the
good messages out.
NOTE: Another method to find the bad message is to try moving all the files
from Imcdata\in to Imcdata\in\temp and from out to out\temp, while the IMC
is still in the locked state. You may receive a message that certain file
can not be moved because it is in use. This file is most probably the
corrupt file that the IMC crashed while trying to process it.
MORE INFORMATION
The same error and symptom may result from a corrupted message in the MTA
store.
For additional information on troubleshooting a corrupted message in the
MTA store, please see the following articles in the Microsoft Knowledge
Base:
ARTICLE-ID: 165505
TITLE : XADM: How to View/Delete Messages in MTS-IN and MTS-OUT
Queues
ARTICLE-ID: Q157323
TITLE : XCON: Identifying and/or Reconstructing a Connector Queue