XADM: Bad Message Causes DR. Watson in Store.exe

Last reviewed: January 30, 1998
Article ID: Q169223
The information in this article applies to:
  • Microsoft Exchange Server, version 5.0

SYMPTOMS

When a bad message is trying to be delivered from the IMCDATA/IN queue to the Store.exe, the following Dr. Watson error message occurs:

   Application error has occurred and an application log is being
   generated. Store.exe exception: 0xc0000005 , address:0x0064897c

The Event log shows the following:

   Event ID: 4097
   Source: DrWatson
   Type: Information
   Category: None
   Description: The application, store.dbg, generated an application error.
   The error occurred on 5/23/1997 @ 14:35:49.328. The exception generated
   was c0000005 at address 0064897c (<nosymbols>)

   Event ID: 4117
   Source: MSExchangeIMC
   Type: Error
   Category: Internal Processing
   Description: An error was returned from the messaging software the
   Internet Mail Service uses to process messages on the Microsoft Exchange
   Server.  As a result, the message in spool file LMNVTL7L failed to be
   delivered. The message has been moved to the IMCDATA\IN\ARCHIVE
   directory.

   Event ID: 4116
   Source: MSExchangeIMC
   Type: Error
   Category: Internal Processing
   Description: An error was returned from the messaging software the
   Internet Mail Service uses to process messages on the Microsoft Exchange
   Server.  It is possible that the piece of mail being processed at the
   time will not be delivered. The message that was being processed has
   been moved to the "BAD" folder.  Use the appropriate utilities found in
   the SUPPORT directory of your Exchange CD to view and manipulate these
   messages.

   Event ID: 4023
   Source: MSExchangeIMC
   Type: Error
   Category: Initialization/Termination
   Description: Unable to start the Internet Mail Service because the work
   threads could not be initialized.

   Event ID: 4037
   Source: MSExchangeIMC
   Type: Error
   Category: Internal processing
   Description: An exception has occurred which was handled internally by
   the Internet Mail Service.  This may have resulted in a message not
   being delivered. Code: 0xc0000005 Flags: 0x00000000 Address: 0x77f1071c


CAUSE

This occurs when a bad message is trying to be delivered from the IMCDATA/IN queue to the store.

WORKAROUND

To work around this problem, move the message(s) from the IMCDATA/IN queue, and then restart the store and the Internet Mail Service.

STATUS

Microsoft has confirmed this to be a problem in versions 5.0, of Microsoft Exchange. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

The following is from an Alpha machine.

The message is failing in:

function: CmcvtrHdr::ulScanForEndOfBracket

        00648a38: 47ebb406 bis     zero,#5d,t5
        00648a3c: c3e00005 br      zero,00648a54
CmcvtrHdr::ulScanForEndOfBracket+54
        00648a40: 47e7d406 bis     zero,#3e,t5
        00648a44: c3e00003 br      zero,00648a54
CmcvtrHdr::ulScanForEndOfBracket+54
        00648a48: d35fffc5 bsr     ra,00648960  CmcvtrHdr::ulSkipComment
        00648a4c: 6be78001 ret     zero,(t6),1
CmcvtrHdrAddress::HrExtractAddress+1a0
        00648a50: 47e45406 bis     zero,#22,t5
        00648a54: 424037b0 cmpule  a2,#1,a0
        00648a58: f600001f bne     a0,00648ad8
CmcvtrHdr::ulScanForEndOfBracket+d8
        00648a5c: 42203011 addl    a1,#1,a1
FAULT ->00648a60: 2c310000 ldq_u   t0,0(a1)
        00648a64: 44603805 xor     t2,#1,t4
        00648a68: 40003000 addl    v0,#1,v0
        00648a6c: 401203ba cmpult  v0,a2,ra
        00648a70: 483100c1 extbl   t0,a1,t0
        00648a74: 42203011 addl    a1,#1,a1
        00648a78: f4a00003 bne     t4,00648a88
CmcvtrHdr::ulScanForEndOfBracket+88
        00648a7c: 47ff0403 bis     zero,zero,t2
        00648a80: f75ffff7 bne     ra,00648a60
CmcvtrHdr::ulScanForEndOfBracket+60
Keywords          : XADM
Component         : IMS
Version           : WINDOWS:5.0
Platform          : WINDOWS
Issue type        : kbbug
Solution Type     : kbworkaround


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: January 30, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.