XCLN: Client Searches for Dcab32.dll on the Network

Last reviewed: July 10, 1997
Article ID: Q169665
The information in this article applies to:
  • Microsoft Outlook 97
  • Microsoft Exchange Windows 95 client, version 4.0
  • Microsoft Exchange Windows 95 client, version 5.0
  • Microsoft Exchange Windows NT client, version 4.0
  • Microsoft Exchange Windows NT client, version 5.0

SYMPTOMS

When you start a Microsoft Exchange client, you might observe that a search is made for a file called Dcab32.dll on the network. This observation would likely be made using a network sniffer.

CAUSE

When the Microsoft Exchange client loads the Address Book Provider DLL (Emsabp32.dll), the DLL searches for the presence of Dcab32.dll to enable Defense Messaging System (DMS) functionality. DMS is discussed in brief at http://www.microsoft.com/exchange/dms.htm. The search for Dcab32.dll will ultimately use the search path in the attempt to find the DLL. If the search path contains a network drive, this drive will also be searched. It is normal for the commercial release of Microsoft Exchange to do this search and fail to find the file.

WORKAROUND

For customers that do not want the Microsoft Exchange client to cause network activity while starting due to the Dcab32.dll search, it is recommended that network drives be removed from the search path. If network drives cannot be removed, a stub DLL can be obtained from Microsoft with the name Dcab32.dll that can be placed in the SYSTEM (on Win95) or SYSTEM32 (on NT) directory of the Microsoft Exchange client. The DLL provides NO DMS functionality, but it will be found by the Microsoft Exchange client search (thereby terminating the search), prior to use of the search path.

When the Microsoft Exchange client determines that the DLL does not contain DMS functionality, the client ignores it and continues loading.

STATUS

Contact Microsoft Technical Support for more information on the availability of this file.


KBCategory: kbbug
KBSubcategory: XCLN
Additional reference words: Search network traffic slow startup
Version : 4.00 5.00
Platform : IDEAS
Issue type : kbbug
Resolution Type : kbfix


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: July 10, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.