XFOR: MS Mail Connector Interchange Rejects Outlook Msgs

Last reviewed: August 1, 1997
Article ID: Q169682

The information in this article applies to:

  • Microsoft Exchange Server, versions 4.0 and 5.0

SYMPTOMS

If you send an Outlook message with a category selected to a Microsoft Mail 3.5 recipient, the message will be rejected immediately by the Microsoft Mail Connector interchange (MSMI). You receive a non-delivery report (NDR) with the error message:

   MS Mail Connector failed parsing the message content.

CAUSE

Outlook send-forms with a category selected contain named properties. These named properties have not been recognized properly by the MSMI. As a result the MSMI generated NDRs.

WORKAROUND

To work around this problem:

  • Do not use categories when sending messages to Microsoft Mail users.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server versions 4.0 and 5.0. A supported fix is now available, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.

How to Install the Fix

  1. Stop the service MSExchangeMSMI.

  2. Back up the following files from the directory <path>\<exchsrvr- install>\Connect\Msmcon\Bin

          Mt.exe
          Mtmsg.dll
          Address.dll
    

  3. Back up the following file from the directory <path>\<exchsrvr- install>\bin

          Address.dll
    

  4. Skip this step if you did not change the installation path for the Admin module (that is, the Admin binary files are located under <Path>\<Exchsrvr-install>\Connect\Msmcon\bin).

    Back up the following file to the directory <Path>\<Exchadmin-install>:

          Address.dll
    

  5. Copy the following files to the directory <Path>\<Exchsrvr- Install>\Connect\Msmcon\Bin:

          Mt.exe
          Mtmsg.dll
          Address.dll
    

  6. Copy the following file to the directory <Path>\<Exchsrvr-install>\Bin

        Address.dll
    

  7. Skip this step if you did not change the installation path for the admin module(that is, the Admin binary files are located under <Path>\<Exchsrvr-Install>\Connect\Msmcon\Bin).

    Copy the following file to the directory <Path>\<Exchadmin-install>:

          Address.dll
    

  8. Restart the service MSExchangeMSMI, as well as any other services you may have stopped in step 1.

MORE INFORMATION

When you increase the diagnostics logging for the MSMI to maximum, you can see the following entry in the Windows NT Server Event Log:

   Event ID: 10000
   Source: MSExchangeMSMI
   Type: Information
   Category: Debug Data
   Description:
   MDBEF Parsing failed for unknown reason
Keywords          : kbfix4.00.sp5 kbfix5.00.sp1 XFOR kbusage buglist4.00 buglist5.00
Version           : 4.0 5.0
Platform          : winnt


================================================================================


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: August 1, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.