XADM: Store Thread's Processor Use Peaks Indefinitely

Last reviewed: February 12, 1998
Article ID: Q178053
The information in this article applies to:
  • Microsoft Exchange Server versions 4.0, 5.0, and 5.5

SYMPTOMS

A thread in the store indefinitely consumes a substantial percentage of processor utilization. In addition, this problem begins to occur at approximately the same time every week. If the spinning thread is viewed in a debugger, the call stack will appear similar to the following:

   035efd50 0045b208 : store!TibNext+0x34
   035efd50 00459fb8 : store!REPL__EcGetNextFtSend+0xd8
   035efd90 0045a0f0 : store!REPL__EcGetNextFtSendStatus+0xc8
   035efdd0 0044f448 : store!REPL__EcSetFtSendStatus+0xc0
   035efe10 00472670 : store!EcReplFolderMessagesSend+0x238
   035efec0 0047283c : store!EcReplSendMessages+0xc0
   035eff10 004713e0 : store!EcReplSendMessagesSelectedTimes+0x7c
   035eff50 005258ac : store!FReplAgent+0x130
   035eff80 77e6cbe8 : store!EcProcessTask+0x1bc

CAUSE

This problem only occurs when a public folder has been selected to replicate to other servers only once a week. The store's thread remains in a loop indefinitely while attempting to calculate the next instance to send a status message.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 5.0.

This problem has been corrected in the latest U.S. Service Pack for Microsoft Exchange Server version 5.0. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K

Microsoft has confirmed this to be a problem in Microsoft Exchange Server versions 4.0 and 5.5.

A supported fix is now available, but has not been fully regression tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Technical Support for more information.


Additional query words:
Keywords : kbbug4.00 kbbug5.00 kbfix5.00.sp2 XADM kbbug5.50
Version : WinNT:4.0,5.0,5.5
Platform : winnt
Issue type : kbbug
Solution Type : kbfix kbpatch


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 12, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.