XADM: Calendar Reminders Not Functioning After Move Mailbox

Last reviewed: February 12, 1998
Article ID: Q178698
The information in this article applies to:
  • Microsoft Exchange Server versions 4.0 and 5.0

IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

SYMPTOMS

After you move a mailbox from one server to another, Calendar and Task reminders no longer work.

CAUSE

Using the Move Mailbox feature of Microsoft Exchange Server corrupts certain properties on search folders. This does not cause any corruption in messages or in the database but does change certain properties on search folders.

A search folder is a View/Sort/Filter of any kind. It does not contain messages but, instead, contains pointers to messages.

WORKAROUND

NOTE: The fix for this problem is only implemented in the Exchange Administrator program for version 5.0. The 5.0 Exchange Administrator program can be used to fix this problem on an Exchange 4.0 server.

After applying the hotfix for this problem, perform the following steps to clean reminders:

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it.

  1. Add the following registry key:

          HKEY_CURRENT_USER\Software\Microsoft\Exchange\MSExchangeAdminCommon
          \CleanReminders
          Type: DWORD
          Value = 1
    

  2. Open the Exchange Administrator program from the server that the hotfix was applied to.
3. Select the desired mailboxes from the Recipients container.
   NOTE: The users should not be logged on to the server when you perform
   these steps.
4. From the Tools menu, select Clean Mailbox. 5. Click OK on the Clean Mailbox dialog box, and then click on the warning
   dialog box.
   Wait until it finishes.
6. Open the Outlook client and log on to the mailbox that encountered the
   reminders problem.

   Result: The reminders folder will be rebuilt, and reminders should be
   visible.

Note: If the registry entry is present and set to 1, the Clean Mailbox feature will ONLY clean the Reminders folder for the selected users. No messages will be deleted.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server version 5.0.

This problem has been corrected in the latest U.S. Service Pack for Microsoft Exchange Server version 5.0. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K

MORE INFORMATION

In order to make the Clean Mailbox feature work as it did before, you will need to do one of the following:

  • Set the registry key (specified in Step 1 above) to the value of 0.

-or-
  • Delete the registry key (specified in Step 1 above).
Keywords          : kbbug4.00 kbfix5.00.sp2 XADM
Version           : WinNT:5.0
Platform          : WINDOWS
Issue type        : kbbug
Solution Type     : kbfix


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Last reviewed: February 12, 1998
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.