XWEB: Error Msg: Sorry! The Microsoft Exchange Server Is Down

Last reviewed: February 18, 1998
Article ID: Q180417
The information in this article applies to:
  • Microsoft Exchange Server, versions 5.0, 5.5
  • Microsoft Exchange Active Server Components, version 5.0
  • Microsoft Outlook Web Access, version 5.5

IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

SYMPTOMS

You may receive the following error message when attempting to access a Microsoft Exchange mailbox via the Microsoft Outlook Web Access (OWA) client:

   Sorry! The Microsoft Exchange Server is down or the HTTP service has
   been disabled by an administrator. Please try your request again later.

CAUSE

Several factors may cause this error to occur. This article discusses how to troubleshoot and resolve these issues.

WORKAROUND

  1. Verify that the HTTP service is enabled at the site level. To do this, follow these steps:

    a. Start the Microsoft Exchange Administrator program.

    b. Select the Protocols object located under the Site\Configuration

          container in which the server is located.
    

    c. Open the HTTP (Web) Site Settings object, and verify that the

          Enable Protocol option is enabled.
    

    NOTE: In some cases where the HTTP protocol has been disabled, the

             Logon.asp screen will reappear and you will not see an error
             message.
    
    

  2. Verify that the Lightweight Directory Access Protocol (LDAP) protocol is enabled at the site or server level and that the Allow Anonymous Access option is enabled for the LDAP protocol at the site or server level. To do this, follow these steps:

    a. Start the Microsoft Exchange Administrator program.

    b. Select the Protocols object located under the Site\Configuration

          container in which the server is located.
    

    c. Verify that the Protocol Enabled option is enabled.

    d. Open the LDAP (Directory) Site Defaults object, and select the

          Anonymous tab.
    

    e. Verify that the Allow Anonymous Access option is enabled.

    f. Now that the site settings have been verified, you need to

          verify the server settings. To do this, select the Protocols object
          of the server you are connecting to.
    

    g. Open the LDAP (Directory) Settings object, and select the Anonymous

          tab.
    

    h. Verify that the Allow Anonymous Access option is enabled.

  3. Verify that the MSExchangeWeb Registry key shown below contains the correct values for the Organization, Site, and Server names of the Exchange Server computer you are connecting to. To do this, follow these steps:

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it.

   a. Start the Microsoft Exchange Administrator.

   b. Note the Organization, Site, and Server names displayed for the
      server you are connecting to.

   c. Start the Registry Editor (Regedt32.exe) on the Microsoft Exchange
      Server computer.

   d. Select the following registry key:

         \Hkey_Local_Machine\System\CurrentControlSet\Services
         \MSExchangeWeb\Parameters

   e. Verify that the following three values match the names found above:

        Enterprise - (Must match the Organization name)
        Site       - (Must match the Site in which the Server is located)
        Server     - (Must match the Server to which you are connecting)

      If any of the above values are incorrect, change them to match the
      names displayed in the Exchange Administrator. NOTE: These values are
      not case sensitive.

   f. Exit the Registry Editor.

   g. In Control Panel/Services, stop and restart the World Wide Web
      Publishing Service. NOTE: You must start and stop the WWW service
      with the Control Panel/Services. In some reported cases, stopping and
      starting the WWW service in the Internet Service Manager program has
      not corrected the problem.

  • Verify that the WWW Anonymous Logon account (IUSR_<machine name>) on the Microsoft Internet Information Server (IIS) is at least a member of the Domain Users and Guests groups. This account must have the proper Windows NT credentials to access the IIS and Microsoft Exchange Server. This may be an issue if you are attempting to access a Microsoft Exchange Server computer located in another domain. Another alternative is to specify an account from the Domain Admins group as the Anonymous Logon account for the WWW service. To change this account, perform the following steps:

    a. Start the Microsoft Internet Service Manager (ISM).

    b. Select the WWW service.

    c. On the General tab, enter an existing Windows NT account name and

          password for the Anonymous Logon option.
    

    d. Click OK and exit the Internet Service Manager.

  • Microsoft Exchange Server version 5.5 introduces a new right (and role) called Search, which controls read access of the Microsoft Exchange directory. To enable this functionality for an account on any object in the Exchange directory, an anonymous account must first be defined on the General tab of the DS Site Configuration object. After this is done, any account can be granted the Search permission on any object in the directory. However, the Anonymous account must also be explicitly granted Search permissions at the Configuration container level.

    To verify whether Search permissions have been enabled within the Exchange directory, check the Permissions tab of the Organization, Site, and Configuration containers. If any account has been given the Search permission, you also need to grant this right on the Configuration container to the Anonymous account specified in the DS Site Configuration object.

    The other alternative is to remove the Search permission for all accounts from each object in the Exchange directory that has this permission set.

  • Verify that all Web Access files have been installed on the server and that they are the proper versions. This scenario may occur if any MAPI- enabled applications (Microsoft Exchange or Outlook clients, UPS systems, and so on) were not closed or disabled before running Setup. Because Exchange is forced to use older versions of certain system files such as Mapi32.dll, the OWA components may not function correctly. To verify that the files are correct, perform the following steps:

    a. Run Exchange Server Setup and choose the Reinstall option. This will

          run through the last successful installation and update any corrupt
          or missing registry entries and system files.
    

    -or-

    a. If you have made any customizations in the \Webdata directory, you

          must back up the directory.
    

    b. Run Exchange Server Setup, choose the Add/Remove option, and remove

          the Active Server (5.0) or Outlook Web Access (5.5) components.
          Complete the Setup to uninstall these components.
    

    c. Run Setup again to add the Active Server or OWA components. This will

          create a clean \Webdata directory.
    

    Keywords          : XWEB kbusage
    Version           : WINDOWS:5.0,5.5
    Platform          : WINDOWS
    Issue type        : kbbug

  • ================================================================================


    THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

    Last reviewed: February 18, 1998
    © 1998 Microsoft Corporation. All rights reserved. Terms of Use.