PRB: "File ["<File>"] Does Not Exist" Printing on LAN Manager

Last reviewed: June 26, 1995
Article ID: Q106354
The information in this article applies to:
  • Microsoft FoxPro for MS-DOS, versions 2.0, 2.5, 2.5a, and 2.5b
  • Microsoft FoxPro for Windows, versions 2.5, 2.5a, and 2.5b

SYMPTOMS

The "File ["<file>"] does not exist" error message occurs while you are printing from a FoxPro program or application on a Microsoft LAN Manager network. However, the file does exist. The filename specified may differ each time the program is run.

CAUSE

When the program attempts to open a file, it looks in a particular directory. If it does not find the file there it tries other directories until the file is found. When LAN Manager's "chartime" timer (which defaults to 250 milliseconds) expires, it sends a spool close message to the workstation, and if the program is in the middle of a search for the next file to open, the program exits incorrectly with the error mentioned above.

RESOLUTION

If the chartime parameter in the LANMAN.INI file for the workstation is set to a sufficiently high value, the program will not be interrupted by the spool close message and will work correctly.

MORE INFORMATION

In LAN Manager version 2.1, the chartime parameter controls the amount of time the spooler waits for additional print data before closing the current spool file and printing it. In earlier versions of LAN Manager, this parameter controls the amount of time to wait for pipe data or comm queue data.

For more information about the chartime parameter and the LANMAN.INI file, refer to the LAN Manager documentation or contact Microsoft LAN Manager Product Support Services.

REFERENCE

"Microsoft LAN Manager Administrator's Reference," version 2.1, page 225


Additional reference words: FoxDos FoxWin 2.00 2.50 2.50a
KBCategory: kbprint kbnetwork kbinterop kbprg kberrmsg kbprb
KBSubcategory: FxprintNet


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: June 26, 1995
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.