BUG: Setup Wizard Makes Disk Image Too Large for Floppy Disk

Last reviewed: December 2, 1996
Article ID: Q122909
The information in this article applies to:
  • Microsoft FoxPro for Macintosh, versions 2.5b, 2.5c, and 2.6a

SYMPTOMS

When building distribution disks using the Setup Wizard (SETUP.APP) for an application or executable file created with the FoxPro for Macintosh Distribution Kit, the disk images may be too large to actually fit onto a floppy disk. This can occur with either the 800 kilobyte (K) or 1.44 megabyte (MB) floppy disk sizes.

NOTE: FoxPro 2.6a does not have the option to create 800K disk images. It can only create 1.44 MB disk images.

CAUSE

Large numbers of small files have been known to cause this. The problem may be hard to reproduce unless a certain combination of files is used.

RESOLUTION

The following modifications to SETUP.APP may correct this problem.

NOTE: These modifications are undergoing further testing and may not work in all situations.

Modifications of the FoxPro SETUP.PJX file (Setup Wizard) are not supported by the FoxPro Microsoft Technical Support team; however, this file can be modified as it is a normal FoxPro Project and Application. The information provided here should be used only by experienced programmers who need to get around the problem described in this article.

  1. Open the Setup project located in the DK Wizard folder installed by the FoxPro for Macintosh Distribution Kit by using this code:

    MODIFY PROJECT SYS(2004)+"DK Wizard:Setup"

  2. From the Project Manager, edit the T_Disks table. Change the entries in the Disksize field to smaller values. The original value for the 1.44 megabyte disks is 1427050. 800952 for the 800 kilobyte disks. Using 1375000 for the 1.44 megabyte disks has been known to fix the problem for that size. Some experimentation may be necessary to find a size that allows for an optimal amount of information to be placed on the disk.

  3. Save the changes to the T_Disks table, close it, and rebuild the application. Remember to replace the version of the application that is located in the FoxPro folder, not just the version in the DK Wizard folder.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.


Additional reference words: FoxMac DK 2.50b 2.50c 2.60a buglist2.50b
buglist2.50c buglist2.60a diskette split size
KBCategory: kbtool kbbuglist
KBSubcategory: FxtoolWizother


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: December 2, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.