PRB: Error: Index Tag Not Found After DELETE TAG ALL

Last reviewed: April 30, 1996
Article ID: Q130242
The information in this article applies to:
  • Microsoft Visual FoxPro for Windows, version 3.0

SYMPTOMS

After issuing the DELETE TAG ALL command, you receive this error:

   Index Tag Not Found.

CAUSE

The error occurs because SET COMPATIBLE is set to DB4. dBASE does not support the ALL clause on the DELETE TAG command. The ALL clause on the DELETE TAG command is unique to FoxPro.

WORKAROUND

To work around this issue, SET COMPATIBLE to OFF, or explicitly identify the tag name with the DELETE TAG command. For example, issue one of the following commands:

   SET COMPATIBLE OFF

   -or-

   DELETE TAG tagname


STATUS

This behavior is by design.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Create a Visual FoxPro table:

    CREATE TABLE mytab (cField1 C(20))

  2. Index on cField1:

    INDEX ON cField1 TAG cField1

  3. Set Compatible to dBASE:

    SET COMPATIBLE TO DB4

  4. Attempt to delete all tags:

    DELETE TAG ALL

The error message "Index Tag Not Found." is now displayed.


Additional reference words: 3.00 VFoxWin
KBCategory: kbprg kbprb kberrmsg
KBSubcategory: FxprgGeneral


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: April 30, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.