BUG: dBASE Report Run by FoxPro Displays Bad Extended Chars

Last reviewed: February 13, 1996
Article ID: Q130666
The information in this article applies to:
  • Microsoft FoxPro for Windows, version 2.6a

SYMPTOMS

If a Converted dBASE report contains Extended (International) characters, the characters are displayed incorrectly when FoxPro runs the report.

CAUSE

FoxPro treats the report as a MS-DOS report running under Windows and displays it using FoxFont. This causes the Extended characters to be displayed incorrectly.

RESOLUTION

Transport the converted report by opening it for modification and saving it. After transporting the converted dBASE report, the Extended characters display correctly.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

When you convert a dBASE report by choosing Convert dBASE files from the Run menu, FoxPro creates an .FRX file for the dBASE report (an .FRM file). The .FRM file is left as is. When you run the .FRX file, extended characters display incorrectly. If this .FRX report is transported, the extended characters display correctly. To transport the converted report, open it for modification.

Steps to Reproduce Problem

  1. Set Codepage=auto in the CONFIG.FPW file.

  2. Start FoxPro, and choose Convert dBASE Files from the Run menu to activate the Convert Files dialog box.

  3. Select the directory that contains a dBASE Report that has Extended characters.

  4. Highlight the dBASE Report (.FRM file) that you want to convert and press ENTER, or double-click the report to select it for processing.

  5. Select the Process option to create a file with the same name as the dBASE report file but with an .FRX extension.

  6. Close the Convert Files dialog box.

  7. Choose Report from the Run menu. Then select the .FRX file created in step 5.

  8. Select the Preview or To Print option. Then click the Run button.

Steps to Transport the Converted Report

  1. Use the Modify Report <Report Name> command, or choose Open from the File menu to open the .FRX file.

  2. In the FoxPro Transporter dialog box, click the Transport and Open button.

  3. Save the report.

  4. Preview or Print the transported report.


Additional reference words: FoxWin 2.60a buglist2.60a
KBCategory: kb3rdparty kbbuglist
KBSubcategory: FxinteropDbase


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: February 13, 1996
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.