FIX: Exiting Extended FoxPro Reboots or Hangs on Novell

Last reviewed: September 22, 1997
Article ID: Q96561
2.00 2.50 MS-DOS kbprg kb3rdparty kbbuglist kbfixlist

The information in this article applies to:

  • Microsoft FoxPro for MS-DOS, versions 2.0 and 2.5

SYMPTOMS

Upon exiting Extended FoxPro for MS-DOS, the "FoxPro/LAN 2.0 - Normal shutdown" message is displayed, and the system either hangs or reboots. This problem may occur on every second exit of FoxPro, or the problem may appear to be random.

CAUSE

This problem is caused by a combination of the following:

  • There are HIMEM.SYS and DOS=HIGH statements in the CONFIG.SYS file, but you are not loading a memory manager such as EMM386.EXE.
  • You are running Extended FoxPro while Novell network drivers are loaded. (The problem occurs whether FoxPro is on the server or on the workstation.)
  • You are loading any of the following while in Extended FoxPro: a printer driver, a library file, or a BIN routine.

The workstation will reboot or hang after exiting FoxPro every second time that all three of the above conditions are met. This problem will never occur on the first exit.

STATUS

Microsoft has confirmed this to be a problem in FoxPro versions 2.0 and 2.5 for MS-DOS. This problem was corrected in FoxPro version 2.5a for MS-DOS.

RESOLUTION

Any one of the following workarounds will solve the problem:

  • Remove DOS=HIGH from the CONFIG.SYS file.
  • Leave DOS=HIGH in the CONFIG.SYS file, but add a memory manager such as EMM386.EXE.
  • Issue a RUN command, such as RUN>NUL DIR, before exiting Extended FoxPro.
  • Run Standard FoxPro instead of Extended FoxPro.
  • Upgrade to FoxPro version 2.5a for MS-DOS or FoxPro version 2.5 for Windows.
  • Edit GENPD.APP to use DRIVER.PRG instead of DRIVER2.PLB. (This will solve the problem only if DRIVER2.PLB is the only library file being used. If you are loading another library or a BIN routine, one of the remaining workarounds will be required.)

To modify GENPD.APP to use DRIVER.PRG instead of DRIVER2.PLB, do the following:

  1. Open the GENPD.PJX file in the GOODIES\PDRIVERS subdirectory.

  2. Edit GEN_PD.PRG.

  3. From the Edit menu, choose Find, and search for "DRIVER.PRG".

  4. Delete the asterisk from the following line:

          * (_PDRIVER = "DRIVER.PRG").
    

  5. Place an asterisk at the beginning of the next command line:

          (_PDRIVER = "DRIVER2.PLB).
    

  6. Close GEN_PD.PRG, saving the changes, and rebuild the project and application. (Note: Be sure to save GENPD.APP in the FOXPRO2 directory or in the directory returned by ?_GENPD.)

The products included here are manufactured by vendors independent of Microsoft; we make no warranty, implied or otherwise, regarding these products' performance or reliability.


Additional reference words: FoxDos 2.00 2.50 buglist2.00 buglist2.50
fixlist2.50a novel
KBCategory: kbprg kb3rdparty kbbuglist kbfixlist
KBSubcategory:
Solution Type : kbfix


THE INFORMATION PROVIDED IN THE MICROSOFT KNOWLEDGE BASE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. MICROSOFT DISCLAIMS ALL WARRANTIES, EITHER EXPRESS OR IMPLIED, INCLUDING THE WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL MICROSOFT CORPORATION OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, CONSEQUENTIAL, LOSS OF BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF MICROSOFT CORPORATION OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES SO THE FOREGOING LIMITATION MAY NOT APPLY.

Last reviewed: September 22, 1997
© 1998 Microsoft Corporation. All rights reserved. Terms of Use.