PRB: Resolving FoxPro Internal Memory Error Messages

Last reviewed: May 29, 1996
Article ID: Q99600
The information in this article applies to:
  • Microsoft FoxPro for MS-DOS, versions 2.0, 2.5, and 2.5a
  • Microsoft FoxPro for Windows, versions 2.5 and 2.5a

SYMPTOMS

After one of the following memory error messages is displayed, FoxPro closes all open files to preserve all data and exits to MS-DOS:

   Internal consistency error.
   Resource Manager Internal consistency error.
   Menu Manager Internal consistency error.
   1004 Use of invalid handle.
   1005 Use of unallocated handle.
   1006 Use of transgressed handle.
   1007 Transgressed node found during compaction.
   1008 Foreign node found during compaction.
   1009 Incorrect handle found during compaction.
   1010 Area size exceeded during compaction.
   1011 Area cannot contain handle.

CAUSE

One of the above error messages is displayed because of a memory conflict or a corrupted FoxPro file.

RESOLUTION

Perform the following troubleshooting steps to resolve this problem:

  1. If the .CDX file is corrupted, do the following; otherwise, go to step 2.

    a. At the MS-DOS prompt, type the following command:

             rename <filename>.cdx <filename>.cbk
    
       b. In the Command window, type the following command:
    
             USE <filename>.dbf
    
       c. Re-create the .CDX file.
    
    

  2. If the .DBF file is corrupted, do the following; otherwise, go to step 3.

    a. Restore the backup .DBF file if you have one. If you have no backup

          file, go to step b.
    

    b. In the FoxPro Command window, type the following commands:

             USE <filename>.dbf
             COPY STRUCTURE TO test.dbf WITH CDX
             USE
             SELECT <an unused work area>
             USE test.dbf
             SELECT test.dbf
             APPEND FROM <filename>.dbf
    
    

  3. If the FOXUSER.DBF file is corrupted, do the following; otherwise, go to step 4.

    a. At the MS-DOS prompt, type the following command:

             RENAME foxuser.dbf foxuser.dbk
    
       b. Restart FoxPro. A new FOXUSER.DBF file is automatically created.
    
    

  4. If the problem is occurring with a distributed application, make sure the .ESO or .ESL files aren't corrupted. If they are, replace the support libraries. If the problem doesn't involve a distributed application, go to step 5.

  5. To determine if there is a memory conflict, perform a clean boot of your computer. For more information on this topic, query on the following words in the Microsoft Knowledge Base:

          clean and boot and unnecessary
    

  6. Disable any video or system ROM shadowing.

  7. To make sure there aren't any hard disk errors, type the following command at the MS-DOS prompt:

          chkdsk /f
    

  8. If steps 1-7 don't resolve the problem, reinstall FoxPro.

MORE INFORMATION

The error may have been caused by a corrupt file, and FoxPro, after trapping for this error message, tries to close all open files in an attempt to prevent further file corruption.

Another possibility is that there is an invalid SET TEMP in the AUTOEXEC.BAT or CONFIG.FPW files.


Additional reference words: FoxDos FoxWin 2.00 2.50 2.50a tshoot conflict
memory corrupt abnormal bnormal program termination ice
KBCategory: kbprg kbprb
KBSubcategory: FxenvFoxuser


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Last reviewed: May 29, 1996
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